×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Kunena 5.1.1.6 Hochkant Bilder werden nicht mehr gedreht

More
2 months 3 weeks ago - 2 months 3 weeks ago #11 by Oerlybird
Hallo Rich,

ich habe mit PHP 7.3 und auch mit PHP 7.4 getestet. Das Verhalten ist das Gleiche.

Ich habe auch in eurem Playground-Forum getestet. Das Verhalten ist das Gleiche wie bei mir!

www.kunena.org/forum/163-Feature-Playgro...24-testbilder#213139
Last edit: 2 months 3 weeks ago by Oerlybird.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #12 by rich
Wir haben es jetzt durchgetestet, Es scheint, dass es nur mit bestimmten Versionen von Chromium der Fall ist.
www.kunena.org/forum/163-Feature-Playground/159624-testbilder
Es gab schon mal ein ähnliches Problem mit Chromium, aber das ist schon zwei Jahre her. Möglicherweise betrifft es nur bestimmte Versionen.
Wird das Bild gedreht, wenn du es am PC direkt mit Chromium öffnest?

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago - 2 months 3 weeks ago #13 by Oerlybird

rich wrote: Wird das Bild gedreht, wenn du es am PC direkt mit Chromium öffnest?

Ja, wenn ich das Bild direkt mit dem Browser am PC öffne wird es richtig gedreht (Chromium-Version ist 83.0.4103.61).

Es wäre mal interessant zu erfahren ob Klausimausi das Problem gelöst hat.
Last edit: 2 months 3 weeks ago by Oerlybird.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #14 by rich
Es ist auch für mich interessant. Welche Kunena-Version hattest du vor dem Upgrade installiert? Wenn du willst, könnten wir es gemeinsam herausfinden, ob es am Browser- oder am Upgrade von Kunena liegt.
Ich installiere die selbe Kunena-Version auf einer meiner Testseiten, die du vor dem Upgrade gehabt hattest und erstelle dir einen Zugang. Dann kannst du ein Bild hochladen. Falls es richtig gedreht wird, aktualisiere ich auf die aktuelle Version und du versuchst es och einmal.
Wenn es danach nicht mehr gedreht wird, liegt es an Kunena. Aber wenn es schon beim ersten Mal (mit der alten Version) nicht gedreht wird, liegt es am Browser.

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #15 by Oerlybird
Hallo Rich,

ich hatte vorher die Version 5.1.15 installiert. Damit hatte es keine Probleme gegeben. Das ist erst ab der Version 5.1.16 aufgetreten. Was mich sehr irritiert ist dass es mit dem Firefox Browser einwandfrei funktioniert, mit dem Chrome aber nicht.

Ich habe jetzt mal ein Testforum mit der Kunena-Version 5.1.15 aufgesetzt. Damit werden die Bilder mit dem Chrome Browser richtig gedreht. Auch nach dem Update auf die Version 5.1.16 werden die Bilder immer noch richtig gedreht.

Merkwürdig ist dass beim Hochladen von meinen Bildern in euer Testforum diese jetzt auch richtig gedreht angezeigt werden. Habt ihr da was geändert?

Please Log in or Create an account to join the conversation.

More
2 months 3 weeks ago #16 by rich

Ich habe jetzt mal ein Testforum mit der Kunena-Version 5.1.15 aufgesetzt.

Sehr gut, dann erübrigt sich mein Vorschlag.

Ich habe festgestellt, dass das Bild, das du mir zum Testen gegeben hast, immer richtig dargestellt wird. Hattest du es bearbeitet, oder neu abgespeichert? Für mich scheint es, dass es zugeschnitten wurde. Es ist das selbe Bild, mit dem du es heute hier versucht hast, deshalb wird es richtig dargestellt. Gestern hattest du mit einem anderen Bild getestet. Du musst das (große) Bild von gestern zum Testen verwenden.

Inzwischen habe ich selbst ein hochkant Foto gefunden, aber es wird auch nicht mit Kunena 5.1.15 gedreht. Hattest du mit dem Upgrade auch gleichzeitig ein Joomla Upgrade durchgeführt?

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #17 by Oerlybird
Hallo Rich,

Joomla und Kunena sind in meinem Forum auf dem aktuellen Stand. Als Template verwende ich Crypsis.

Ich habe jetzt mal mit den Templates Blue Eagle 5 und Aqidah Ku von JoomlaTema getestet. Mit beiden Templates werden die Bilder richtig gedreht. Ich möchte eigentlich das Template nicht wechseln weil unsere Forenmitgleder an das Crypsis Template gewöhnt sind.

Es wäre schön wenn baldmöglichst eine Crypsis-Version zur Verfüngung stehen würde bei dem die Bilder richtig gedreht werden.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #18 by rich

Ich habe festgestellt, dass das Bild, das du mir zum Testen gegeben hast, immer richtig dargestellt wird. Hattest du es bearbeitet, oder neu abgespeichert? Für mich scheint es, dass es zugeschnitten wurde.

Es war ein Fehler von mir, dieses Bild von dir enthält die Exif Orientierungsdaten. Vielleicht hatte ich es selbst beim Testen mal zwischengespeichert.
Ich habe dieses Thema nicht vergessen und mit älteren Kunena-Versionen getestet. Dabei bin ich so weit zurück gegangen, bis zu Versionen, die nicht mehr mit Joomla 3.9.18 funktionieren.
Mit allen Versionen war das selbe Problem, mein Testbild wurde nicht gedreht und deines wird richtig angezeigt. Daher habe ich dann festgestellt, dass dies nur bei Bildern passiert, welche die Größe der erlaubten Einstellungen überschreiten.
Ändere die Bildeinstellungen auf deiner Testseite bei „Max. Größe der Bilddateien, Max. Bildbreite, Max. Bildhöhe“ zu einem höheren Wert.
z.B.: wenn das Bild 2 MB und eine Größe 4000 x 3000 hat, wähle 2100kB, Breite 4100, Höhe 4100. Du wirst sehen, dass es richtig gedreht wird.

Jetzt stellt sich natürlich die Frage, warum ist es nicht früher aufgefallen, obwohl dies auch bei älteren Kunena-Versionen das selbe ist.
Könnte es sein, dass jene Benutzer, bei denen es auftritt, in höchster Auflösung fotografieren, sodass die Größe überschritten wird? Die Kameras werden immer besser, und die Benutzer laden die Bilder unbearbeitet hoch. So kann es schon mal dazu kommen, dass manche Bilder bis zu 9000px haben.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago - 2 months 2 weeks ago #19 by Klausimausi
Hiho,

verfolge den Threat hier weiterhin mit Interesse. Meine Anmerkung zur Fotogröße: Habe seit Ewigkeiten Max. Bildbreite: 1680 und Max Bildhöhe 1280px... Also das kann es irgendwie nicht sein... Die Probleme traten erst mit der letzten Version auf.... :(

Hmm nee moment. Edit: Also das ist also aktuell mit der Größe? Ich würde aber ungern so große Fotos von 9000px Breite zulassen, da entweder die Kompression zu starke Artefakte hervorrufen würde oder die Dateien zu groß. Gerade für die mobile User....

LG,
K.
Last edit: 2 months 2 weeks ago by Klausimausi.

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #20 by rich

Meine Anmerkung zur Fotogröße: Habe seit Ewigkeiten Max. Bildbreite: 1680 und Max Bildhöhe 1280px... Also das kann es irgendwie nicht sein... Die Probleme traten erst mit der letzten Version auf....

Dem widerspricht aber wieder, da ich es mit den vorangegangenen Versionen getestet habe und damit das selbe Problem auftritt.
Deine erlaubte Bildgröße ist durchaus in Ordnung und wenn du es mit dem Bild versuchst, welches Oerlybird hier als Zip verpackt hochgeladen hat, dann siehst du, dass es richtig gedreht wird, da es deine erlaubte Größe nicht überschreitet.

Mich würde interessieren, wie groß das originale Bild ist, welches hochgeladen- und nicht gedreht wurde. Es ist sicher über dem erlaubten Wert.

Ich würde aber ungern so große Fotos von 9000px Breite zulassen, da entweder die Kompression zu starke Artefakte hervorrufen würde oder die Dateien zu groß.

Ich gebe dir recht, das würde ich auch nicht zulassen.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.131 seconds