×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Solved Kunena 503 auf Joomla 3.6.4 schlägt fehl

More
3 years 2 months ago - 3 years 2 months ago #1 by Best-Of-Me
Hallo zusammen,

ich möchte Kunena auf eine frisch installierte Joomla Seite installieren. Jedoch schlägt die Installation wg. eines Datenbankfehler ständig fehl.

Es erscheint die Meldung: Installation wird vorbereitet

Installation vorbereiten ... OK
Installiere Kunena - Alphauserpoints Plugin ... OK
Installiere Kunena - Altauserpoints Plugin ... OK
Installiere Kunena - Community Plugin ... OK
Installiere Kunena - Comprofiler Plugin ... OK
Installiere Kunena - Easyprofile Plugin ... OK
Installiere Kunena - Easysocial Plugin ... OK
Installiere Kunena - Gravatar Plugin ... OK
Installiere Kunena - Uddeim Plugin ... OK
Installiere Kunena - Kunena Plugin ... OK
Installiere Kunena - Joomla Plugin ... OK


Anschließend heißt es in der Überschrift, Installation Fehlgeschlagen. Als Joomla Meldung erscheint:

Table 'DB2740107.#__kunena_configuration' doesn't exist SQL=SELECT * FROM #__kunena_configuration WHERE id=1

Habt ihr eine Idee womit das zusammenhängen könnte?
Last edit: 3 years 2 months ago by Best-Of-Me.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #2 by rich
Diese Meldung sollte eigentlich nur kommen, wenn keine Konfiguration gespeichert ist (oder werden kann).
Nachdem der Vorschlag in diesem Thema nichts gebracht hat, versuche bitte folgendes:

1) entferne die Ordner Kunena
administrator/components/com_kunena
components/com_kunena
libraries/kunena
2) leere den Cache
3) entferne in der Datenbank alle Kunena tabellen
4) überprüfe die Berechtigungen (Admin Tools)
5) Installiere Kunena erneut
Last edit: 3 years 2 months ago by rich.

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #3 by Best-Of-Me
Klappt leider nicht.

Hätte mich auch gewundert, da es ja bereits auf einer frischen Joomla Installation nicht funktioniert hat... Scheinbar ist in der Installationsroutine etwas nicht in Ordnung...

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #4 by rich
Hm.. dieser Fehler wurde schon öfters gemeldet, aber es gelingt uns einfach nicht, diesen zu reproduzieren. Kontrolliere bitte mal in der Datenbank, ob diese Tabelle *_kunena_configuration erstellt wurde, oder ob diese fehlt. Insgesamt sollten es 23 Tabellen sein.
Versuche bitte folgendes:
Zuerst kontrolliere in „Erweiterungen -> Verwalten -> Datenbank“ ob alles in Ordnung ist. Wenn ein Fehler angezeigt wird, klicke auf reparieren.
Danach entferne alle Kunena Tabellen aus der Datenbank
Danach versuche die Installation von Kunena 4.0.12
Falls es funktioniert hat, aktualisiere dann auf Kunena 5.0.3

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #5 by Best-Of-Me
Da scheinen wir doch schon das Problem gefunden zu haben. Bei mir sind nur 4 Datenbanken angelegt worden

_kunena_aliases
_kunena_announcement
_kunena_configuration
_kunena_version

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #6 by Best-Of-Me
Mit 4.0.12 erscheint das selbe Fehlverhalten. Siehe Screenshot.
Attachments:
The following user(s) said Thank You: zugo1972

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #7 by rich
Die Rechte und auch der Besitzrechte sind in Ordnung? Ftp ist ebenfalls deaktiviert?
The following user(s) said Thank You: zugo1972

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago #8 by Best-Of-Me
Ich habe den Fehler gefunden!

Ich habe meine Webseite bei Strato gehostet. Im Adminbereich bietet Strato eine Joomla Installation an (AppWizard). Wenn ich Joomla darüber installiere, funktioniert die Kunena Installation nicht.

Jetzt habe ich aber mal die kompletten Joomla Dateien per FTP übertragen (mit DSL 3.000 ein riesen Spaß). So funktioniert es nun tadellos!
The following user(s) said Thank You: rich, Goldamar

Please Log in or Create an account to join the conversation.

More
3 years 2 months ago - 3 years 2 months ago #9 by rich
Danke dass du uns die Ursache mitgeteilt hast. Dieser Installationsfehler wurde schon öfter gemeldet, somit können wir auch das in Betracht ziehen.
Last edit: 3 years 2 months ago by rich. Reason: Tippfehler

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #10 by Goldamar
Ich hatte das gleiche Problem, hab dann auch manuell installiert und es funktioniert!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.236 seconds