×
Kunena 5.2.6 released and Blue eagle 1.6.6 released (25 Jul 2021)

The Kunena team has announce the arrival of Kunena 5.2.6 [K 5.2.6] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.2 and issues discovered during the development stages of K 5.2.6

Solved [gelöst] Farben in Whois Legende ändern

More
6 years 10 months ago - 6 years 10 months ago #1 by Trainman
Hallo zusammen,

wie der Titel verrät habe ich Probleme mit der farblichen Darstellung der Legende im Kunena-Forum.

Fehler:
Bei mir sind alle Titel der Legende nur in Grau (also Farblos) dargestellt, obwohl ich im Backend beim Template unterschiedliche Farben eingetragen habe.

Versionen die ich verwende:
Joomla 3.3.6 Stable German
Kunena v3.0.6
Mein Joomla Template ist ein Yootheme ( Mein Joomla Template )
Mein Kunena Template mit dem Problem ( Mein Kunena Template )

Meine Ansätze:
Ich habe natürlich nach dem Fehler gesucht und bin hier auf zwei Threads gestoßen:
[gelöst] Legende farblich anpassen
Hier wird am Ende nochmal gesagt, wo die Änderungen getätigt werden, nämlich in der Joomla Template.css. Eine einfache Template.css besitzt mein Yootheme leider nicht, stattdessen ist es im Ordner css aufgesplittet. Da habe ich nach Kunena einträgen gesucht, bin aber nicht fündig geworden.

Legende bearbeiten
In diesem Thread geht man auf die gleiche css Datei ein, der Joomla Template.css. Wie erwähnt existiert die bei mir nicht aber ich habe die genannten Einträge in der
components/com_kunena/template/Mein Template/css/kunena.default.css
gefunden. In der Lösung soll man die Codes dementsprechend einsetzen.
In einer dritten Lösung außerhalb dieses Forums wird ebenfalls von dem Eintrag "!important" gesprochen, der eingetragen werden soll.

In meiner (dieser) kunena.default.css ist aber jeder Farbeintrag bereits mit !important versehen ohne das ich etwas eingetragen habe. Er sieht bspw. für den Moderator so aus:
color: var(styleUserGlobalModerator) !important;


Nun ist meine Frage, wie ich das Problem noch beheben könnte?
Außerdem frag ich zu Sicherheit direkt mal danach wie es sich mit den Namen in der Whois selbst verhält denn mehrfach habe ich auch gelesen, das die Farben der Legende zwar angezeigt werden aber die Namen in der Whois dann ebenfalls wieder Farblos erscheinen. das Problem möchte ich zur Not direkt mit lösen.

LG und besten Dank

EDIT:
Genau mein Eintrag der Farbe
color: var(styleUserGlobalModerator) !important;
hat den Fehler verursacht. Vermutlich liegt es an der Version des Kunena Templates (für 2.x), weshalb hier nicht wie im aktuellen direkt die Farben per html code genutzt wurden.
Ich habe also die ersten Einträge alle durch html Farben ersetzt und siehe da, sie sind Farblich.
Tatsächlich wurden bei mir dann die Whois Namen immernoch nicht farblich dargestellt. Das liegt daran, das mein Template zwei seperate Einträge (die befinden sich in der gleichen .css direkt darunter) nutzt, die aber mit dem gleichen Platzhalter der Farbe versehen war.
Einfach hier ebenfalls den Eintrag durch html Farbcodes ersetzen (am besten der gleichen ^^) und schon ist alles so wie es sein soll.

Vermutlich sind dann jegliche Farbeinstellungen zu den Namen im Backend (Adminpanel) unwirksam aber das stört mich nicht. Ich möchte die Farben ja beibehalten und nicht jede Woche ändern :laugh: .

LG und Danke trotzdem.
Last edit: 6 years 10 months ago by Trainman. Reason: Fehler gelöst

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.093 seconds