Kunena 6.3.1 released

The Kunena team has announce the arrival of Kunena 6.3.1 [K 6.3.1] in stable which is now available for download as a native Joomla extension for J! 4.4.x/5.0.x/5.1.x. This version addresses most of the issues that were discovered in K 6.2 / K 6.3 and issues discovered during the last development stages of K 6.3

This category contains miscellaneous, uncategorised third-party extensions (e.g. JomSocial, Community Builder, etc.) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, the ideas in these topics may not work with later versions and, for that reason, the topics are locked.

Important ObjectClarity Kunena Discussbot released!

More
15 years 3 months ago #11 by rinuccio
Ive post on your forum...

Update notice
The topic has been locked.
More
15 years 3 months ago #12 by mijalis
I wrote some comments, but then the related article cannot be displayed:
Code:
[K-DISCUSSBOT DEBUG: Discussbot called with row->id=5. ] [K-DISCUSSBOT DEBUG: Article is not being displayed on the Front Page ] [K-DISCUSSBOT DEBUG: Using Auto-Mode to discuss article in FB CategoryId:2 ] [K-DISCUSSBOT DEBUG: Rendering the bot... ] [K-DISCUSSBOT DEBUG: Kunena Config loaded from the DB. ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): discussbot=[1] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): joomlastyle=[0] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): template=[default_ex] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): board_ofset=[0] ] [K-DISCUSSBOT DEBUG: Found the FB threadId in the cross reference table(#__fb_discussbot). ] [K-DISCUSSBOT DEBUG: User is a moderator. ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): pubwrite=[0] ] [K-DISCUSSBOT DEBUG: User has permission to post in FB category 2. ] [K-DISCUSSBOT DEBUG: User is logged in. ] [K-DISCUSSBOT DEBUG: Article Id is 5 ] [K-DISCUSSBOT DEBUG: Counted 2 actual post(s) in this thread #7. ] [K-DISCUSSBOT DEBUG: Rendering Comments with 2 actual posts. ] [K-DISCUSSBOT DEBUG: Limiting rendered comments to 3 posts. ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): avatar_src=[fb] ] [K-DISCUSSBOT DEBUG: Showing Last posts in the thread in Ascending order. ] Notice: Undefined variable: mainframe in C:\wamp\www\joomla159\components\com_kunena\class.kunena.php on line 26 Fatal error: Call to a member function getCfg() on a non-object in C:\wamp\www\joomla159\components\com_kunena\class.kunena.php on line 26
The topic has been locked.
More
15 years 3 months ago - 15 years 3 months ago #13 by guerilla
i installed it but when i open a discussed article i got this characters with blank page:



what is the problem?

EDIT:
installed new version (1.8e) and solved
Last edit: 15 years 3 months ago by guerilla.
The topic has been locked.
More
15 years 3 months ago #14 by batmonkey
I'm getting the following error from the discussbot:
Code:
[K-DISCUSSBOT DEBUG: Discussbot called with row->id=35. ] [K-DISCUSSBOT DEBUG: Article is not being displayed on the Front Page ] [K-DISCUSSBOT DEBUG: Searching for {mos_fb_discuss:#} tag in article text... None found. ] [K-DISCUSSBOT DEBUG: Using Auto-Mode to discuss article in FB CategoryId:2 ] [K-DISCUSSBOT DEBUG: Rendering the bot... ] [K-DISCUSSBOT DEBUG: Kunena Config loaded from the DB. ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): discussbot=[1] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): joomlastyle=[0] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): template=[default_green] ] [K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): board_ofset=[-2] ] Fatal error: Call to undefined function check_dberror() in /home/mysite/public_html/components/com_kunena/class.kunena.php on line 99

This seems directly related to the 1.0.8 install, as it's duplicating the error (last line above) I got from an old "recent posts" module when I tried updating. Is there a hack available to make this work? Or maybe someone can just point me in the direction of whatever function got renamed/moved in the new version?

Crossposted here on the upgrade problem thread and at Object Clarity

Thanks!
The topic has been locked.
More
15 years 3 months ago #15 by dbosnj35
kunena 1.0.8
joomla 159
instaled discusbot an i get this error when i click on my article where I put the code for calling up the discusbot

Error:
Warning: preg_replace() [function.preg-replace]: Unknown modifier '>' in /home/dr2vabr9/public_html/plugins/content/kdiscussbot.php on line 597
The topic has been locked.
More
15 years 3 months ago - 15 years 3 months ago #16 by nzjacob
dbosnj35 wrote:

kunena 1.0.8
joomla 159
instaled discusbot an i get this error when i click on my article where I put the code for calling up the discusbot

Error:
Warning: preg_replace() [function.preg-replace]: Unknown modifier '>' in /home/dr2vabr9/public_html/plugins/content/kdiscussbot.php on line 597


If you have the text {mos_fb_discuss:id} with any formatting (italics or bold etc) you will get this error.

You need to make sure you check the article and insure there is no formatting here.

If you copied and pasted from the Kunena admin page the text, the part "id" is in italics and its formatting can be left over. Simply highlight the whole text, set to italic and then unset - should solve the problem.

Did for me.
Last edit: 15 years 3 months ago by nzjacob.
The topic has been locked.
More
15 years 3 months ago #17 by dbosnj35
Thanks, that did it. But now I have another error. When I go to article i see massage to comment on it and after I do that it makes thread in forum OK but next time I click on article for I get this:

Fatal error: Call to a member function getCfg() on a non-object in /home/dr2vabr9/public_html/components/com_kunena/class.kunena.php on line 26
The topic has been locked.
More
15 years 3 months ago - 15 years 3 months ago #18 by Timi
Here's what I get...

[K-DISCUSSBOT DEBUG: Discussbot called with row->id=8. ]
[K-DISCUSSBOT DEBUG: Article is not being displayed on the Front Page ]
[K-DISCUSSBOT DEBUG: Using Auto-Mode to discuss article in FB CategoryId:3 ]
[K-DISCUSSBOT DEBUG: Rendering the bot... ]
[K-DISCUSSBOT DEBUG: Kunena Config loaded from the DB. ]
[K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): discussbot=[1] ]
[K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): joomlastyle=[0] ]
[K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): template=[ja_sanidineii_light] ]
[K-DISCUSSBOT DEBUG: Kunena Config(CKunenaConfig,DB): board_ofset=[0] ]
Fatal error: Call to undefined function check_dberror() in /home/******/public_html/components/com_kunena/class.kunena.php on line 61
Last edit: 15 years 3 months ago by Timi.
The topic has been locked.
More
15 years 3 months ago #19 by 4umfreak
@Timi,
Your error is specific to sites that use jomsocial with the discussbot...

Sent you a PM.
The topic has been locked.
More
15 years 3 months ago #20 by dbosnj35
dbosnj35 wrote:

Thanks, that did it. But now I have another error. When I go to article i see massage to comment on it and after I do that it makes thread in forum OK but next time I click on article for I get this:

Fatal error: Call to a member function getCfg() on a non-object in /home/dr2vabr9/public_html/components/com_kunena/class.kunena.php on line 26


OK, yesterday was published new version of discussbot and solved my problem. Respect.
The topic has been locked.
Time to create page: 0.591 seconds