×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× This category contains miscellaneous, uncategorised user contributions, (templates, modules, plugins and hacks) relating to older versions of Kunena that are no longer supported.

This category may also contain a few topics relating to K 1.6 that may have been moved here possibly by mistake.

The topics in this category are for historical interest only. Owing to the structural differences between K 1.6 and K 1.7, these ideas in these topics will not work with later versions and, for that reason, the topics are locked.

Important K 1.5 latest posts module - no longer supported or maintained. Do NOT use this with K 1.6!

More
9 years 11 months ago #351 by sytoedov
I've also found strange issue on one of my configurations.
Using the module wastes extra 10Mb of RAM.
Investigating the culprit I've found that the reason is in loading Community Builder object. Removed the line - got minus 10Mbs of RAM.

I've also found that actually module uses the 5% of the huge Community Builder functionality. I've made special CB class without extra functionality - and this helped me - module was completely function but I've saved 10 Mb.

This was made by the very dirty hack (I am not a developer) so I am just pointing at this trouble - may be this will help someone.

I've done this with CB 1.2.1 and Kunena Latest Module 1.0.45

-- Dam

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #352 by fxstein
Not sure who the author is of that module, but I would recommend to at least limit the amount of data processed by the query.

I would at least limit to the latest 10-30 days. That WHERE criteria will limit the amount of processing significantly.

Hope this helps!

fxstein

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #353 by jpc0480
This is the error I'm getting:

Fatal error: Cannot redeclare class smile in /home/content/w/o/o/woozabee/html/components/com_kunena/template/default/smile.class.php on line 31

I am using a custom template with Kunena 1.5.6 and installed the latest version of this mod. Not sure if my custom template is causing this or what...

Kunena 3.0.4
CB 1.9.1
Joomla 2.5.18

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #354 by jerry
jpc0480 wrote:

This is the error I'm getting:

Fatal error: Cannot redeclare class smile in /home/content/w/o/o/woozabee/html/components/com_kunena/template/default/smile.class.php on line 31

I am using a custom template with Kunena 1.5.6 and installed the latest version of this mod. Not sure if my custom template is causing this or what...

well could be, youst send us template, we will see if we can help or not.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #355 by jerry
sytoedov wrote:

I've also found strange issue on one of my configurations.
Using the module wastes extra 10Mb of RAM.
Investigating the culprit I've found that the reason is in loading Community Builder object. Removed the line - got minus 10Mbs of RAM.

I've also found that actually module uses the 5% of the huge Community Builder functionality. I've made special CB class without extra functionality - and this helped me - module was completely function but I've saved 10 Mb.

This was made by the very dirty hack (I am not a developer) so I am just pointing at this trouble - may be this will help someone.

I've done this with CB 1.2.1 and Kunena Latest Module 1.0.45

-- Dam

send me that hack, I will see how dirty it is and i will decide, if it will be included or not.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago - 9 years 11 months ago #356 by Kona Pete
Hi Jerry,

I just installed the your module with Joomla 1.5.9 and Kunena 1.0.8 and when I enable it, I'm not able to access the site from the front end. I get "HTTP 500 Internal Server Error". Any idea what might be causing this?

Thanks, Kona Pete
Last edit: 9 years 11 months ago by Kona Pete.

Please Log in or Create an account to join the conversation.

More
9 years 11 months ago #357 by jerry
Kona Pete wrote:

Hi Jerry,

I just installed the your module with Joomla 1.5.9 and Kunena 1.0.8 and when I enable it, I'm not able to access the site from the front end. I get "HTTP 500 Internal Server Error". Any idea what might be causing this?

Thanks, Kona Pete

Probably you should upgrade to Joomla 1.5.15 and Kunena 1.5.7, really that's the most tested platform. Your site is vulnerable right now. I am not testing it with that old configuration.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #358 by jpc0480
jerry wrote:

jpc0480 wrote:

This is the error I'm getting:

Fatal error: Cannot redeclare class smile in /home/content/w/o/o/woozabee/html/components/com_kunena/template/default/smile.class.php on line 31

I am using a custom template with Kunena 1.5.6 and installed the latest version of this mod. Not sure if my custom template is causing this or what...

well could be, youst send us template, we will see if we can help or not.


File size is too large... Do you have somewhere else I can send it to you? The file size is 521kb.

Kunena 3.0.4
CB 1.9.1
Joomla 2.5.18
Last edit: 9 years 10 months ago by jpc0480.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago - 9 years 10 months ago #359 by jerry
jpc0480 wrote:

jerry wrote:

jpc0480 wrote:

This is the error I'm getting:

Fatal error: Cannot redeclare class smile in /home/content/w/o/o/woozabee/html/components/com_kunena/template/default/smile.class.php on line 31

I am using a custom template with Kunena 1.5.6 and installed the latest version of this mod. Not sure if my custom template is causing this or what...

well could be, youst send us template, we will see if we can help or not.


File size is too large... Do you have somewhere else I can send it to you? The file size is 521kb.

Try to upload it to some upload service like rapidshare... and put here link.
Last edit: 9 years 10 months ago by jerry.

Please Log in or Create an account to join the conversation.

More
9 years 10 months ago #360 by girathryn
Hi there,

Thanks for this module! One little thing I noticed is that when a post title is small enough to fit on one line in the module (next to its avatar), it throws off the alignment of the avatar/latest post beneath it. Any idea how to fix this?

Thanks!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.148 seconds