×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× This category is for the module developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the module developed for K 1.6 and later versions.

Question Kunena login and 404

More
8 years 6 months ago - 8 years 6 months ago #11 by janaf
Replied by janaf on topic Re: Kunena login and 404
Just tested and got the 404

The 404 is before login has processed; I could not log on successfully.

I could log on with the default Joomla login, but looging out via the Kunena login module, again gave a 404, and I remained logged in.

And apologies about the version. Of course, I am using 1.7.1 :blush:


This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 60 seconds | Max execution memory: 256M | Max file upload: 16M

This message contains confidential information

Joomla default template details : beez_20 | author: Angie Radtke | version: 1.7.0 | creationdate: 25 November 2009

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.1 | creationdate: 2011-11-16

Kunena version detailled: Installed version: 1.7.1 | Build: 5162 | Version name: UnderUret | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled | Kunena Search 1.7.1

Modules: Kunena Latest 1.7.1 | Kunena Stats 1.7.1 | Kunena Login 1.7.1

Last edit: 8 years 6 months ago by janaf.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #12 by hellilyntax
did u user avatar for that profile?

i had encountered 404 page before. it giving me headache.
some users can't login at kunena login module. i can't view user lists either from forum or admin panel.

then i found that some users used .png format as their avatar. so, i've to edit those record manually using phpmyadmin. there is no other way.
then, everything is ok but i'm still looking into permanent solution. right now, i just inform users not tupload any png file for their avatar.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #13 by sozzled
Replied by sozzled on topic Re: Kunena login and 404
@janaf: I visited your website. It obvious that you have modified some Kunena PHP source code (which is OK, of course, because Kunena is an open source product. But I think it's asking a bit much to expect that, after ripping out chunks of Kunena source code, someone should expect the Kunena project to provide you with support.

My advice is to use the original software, supplied with the Kunena installation package, and check that things work with that.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #14 by janaf
Replied by janaf on topic Re: Kunena login and 404
Hi,

Well I was not exactly requesting support. Another poster asked about this and I asked if there was a solution. I also explained that I disabled the module since and was not using it, but offered to help if there was anything I could do.

At that time I got a minor bashing for offering to help, despite not having the module installed. So I installed.

EDIT: By the way, the initial problem I had was when the forum was just installed, plain vanilla. I got the 404 then and have not used the login module it since.

I have now disabled the login module and will not offer to help again and will not ask any more questions.
Last edit: 8 years 6 months ago by janaf.

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago - 8 years 6 months ago #15 by sozzled
Replied by sozzled on topic Re: Kunena login and 404
No-one (and I mean me in particular) has been hammering you for asking a question on this forum, janaf. I think you've misunderstood our intentions and I apologise if I've conveyed the wrong impression. What we're trying to establish is how the Kunena login, installed, out-of-the-box, according to standard Joomla installation and module setup processes, creates these 404 errors.

Joomla 404 errors exist, usually, because there is a problem with the Joomla menu somewhere. 404 errors occur more frequently on websites where SEO/SEF urls are involved - as a general rule - than because of a problem with a login module. 404 errors and login modules (whether we're discussing the Kunena Login module or an other one) tend to occur more if there's a wrong redirection link entered for as a module setting. I'm sure you were probably already aware of that.

I visited your website; I can't immediately see anything specifically wrong with the way you've setup your menu. I can't tell, for your config. report, how you've implemented SEO (for this is almost always associated with 404 errors). The HTML looks like there's been some kind of code compression but, again, I don't know what you might have used for code compression/aggregation. In other words, trying to compare your website with other websites that are based on a fairly standard Joomla installation, we're trying to understand why you (and others) have (or had) a problem. If you could, for a moment, accept the minor criticism I've made regarding what you've done on your site, and look at the possibility that maybe some minor change you've made caused the problem, we might resolve this issue sooner if both sides are willing to collaborate on finding a solution. However, I understand your reluctance to do that now and I suppose we'll just have to settle on the fact that, in your case, you cannot use the Kunena Login module ... and we don't know why that is the case.

I wish you the best of luck for the future.
Last edit: 8 years 6 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 5 months ago #16 by derrickh
Replied by derrickh on topic Re: Kunena login and 404
I was also getting a 404 when using the Kunena Login module. I was able to correct it by going into the Kunena admin, Configuration -> Integration and then setting the 'Login and Registration' field to 'Joomla' (it was previously set to none or auto detect0

I hope that helps.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #17 by sorcio
Hi
I'm really new to Kunena. I read some documentation, also related to my problem but didn't work out.
I installed kunena 1.7.2 within my joomla website.
With default tenplate everything seems to work fine.
But when I try to change it, no matter which I use, I always have a 404 error when trying to login and logout!!

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #18 by sorcio
Replied by sorcio on topic Re: Kunena login and 404
Same problem here, although I have it only with NOT default template!
With any template but default it won't work.
kunena 1.7.2

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #19 by sozzled
Replied by sozzled on topic Re: Kunena login and 404
sorcio: If you do not have a problem using the Kunena Blue Eagle template then you have one solution. If you have problems using a third-party Kunena template then please refer your question to the author of that template to find out if there is a solution. Thank you.

Please Log in or Create an account to join the conversation.

More
8 years 3 months ago #20 by sorcio
Replied by sorcio on topic Re: Kunena login and 404

sozzled wrote: sorcio: If you do not have a problem using the Kunena Blue Eagle template then you have one solution. If you have problems using a third-party Kunena template then please refer your question to the author of that template to find out if there is a solution. Thank you.


Ok thanks for the reply anyway it's just that any other template give me the same problem!
That seemed odd. Maybe it's just because a specific template for 1.7.2 kunena hasn't been done yet; I only found templates for 1.6 version. I downloaded them from here (your extension directory I guess).
www.kunena.org/ked/templates
I couldn't find any template for 1.7, do you know one?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds