×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× This category is for the plugin developed, endorsed, maintained and supported by the Kunena project team. The topics in this category only relate to the plugin developed for K 1.6 and later versions.

Merged Kunena Discuss v 1.6.4 shows the number "1" in top of ALL articles - why?

More
8 years 3 weeks ago - 8 years 3 weeks ago #21 by sozzled
This problem has been resolved in a new version of Kunena Discuss that will be released very soon.

In the meantime, for anyone who wants to know how to fix this problem, the answer - again - is:

(1) If you are using Kunena Discuss 1.6.4, edit the file kunenadiscuss.php, find the following code
if ($kunenaCategory || $kunenaTopic) {
				self::$plgDisplay [$article->id] = $this->showPlugin ( $kunenaCategory, $kunenaTopic, $article, $show == 1 );
			}
		} // end of $ksource!='kunena' check
 
		return true;
	}
 
	// *** display content ***
	protected function display($context, &$article, &$params) {
		if (isset ( self::$plgDisplay [$article->id] )) {
			$this->debug ( "onAfterDisplayContent: Returning content for article {$article->id}" );
Remove the line 235 that says "return true;", like this:
if ($kunenaCategory || $kunenaTopic) {
				self::$plgDisplay [$article->id] = $this->showPlugin ( $kunenaCategory, $kunenaTopic, $article, $show == 1 );
			}
		} // end of $ksource!='kunena' check
 
//		return true;
	}
 
	// *** display content ***
	protected function display($context, &$article, &$params) {
		if (isset ( self::$plgDisplay [$article->id] )) {
			$this->debug ( "onAfterDisplayContent: Returning content for article {$article->id}" );
(2) If you can't do this simple thing, you can download (and extract from the .ZIP file) an edited version of kunenadiscuss.php from either of these two places:
  • msg #38 of Number Thingy; or
  • msg #4 of In Category Blog view, all of the comments and the quick reply form is shown after the article title .
We assume that you know where, on your server, the file kunenadiscuss.php is located. Do you know which file on your server you need to replace?
Last edit: 8 years 3 weeks ago by sozzled.
The topic has been locked.
More
8 years 3 weeks ago #22 by Netthandel
Hi,
The case is that I HAVE done that :-)

I am no novice, even though I am pretty new here at this forum. Been using Joomla since the day it was birth from Mambo, and have done a lot of core hacks (in the past) in both Joomla, CB, Group Jive etc. Now it's none core hacks anymore, and onlu JomSocial and Kunena and EasyBlog :-)

However I don't have the "1" issue any longer, BUT I can not control what is shown on the front page. It either shows full discuss - or nothing anywhere.

Attached is my current file shown in DreamWeaver :-)
Attachments:
The topic has been locked.
More
8 years 3 weeks ago - 8 years 3 weeks ago #23 by sozzled
This topic is only about the number "1" appearing at top of all articles. As you say, you've fixed that issue. That's good. The other matter you raise is off-topic to this discussion. You should use another topic for your discussion.

The last time we had a topic about this "number 1" issue, someone else also went off-topic and we had to lock the topic because it became too confusing. That is what is happening this time.

The subject of this topic is "Kunena Discuss v 1.6.4 shows the number "1" in top of ALL articles - why?". For other people who want the answer to this question, the answer is given in msg #2 of this topic and the answer is repeated in msg #21. This "number 1" problem that affects KD 1.6.4 has been fixed in Kunena Discuss 1.7.

This topic is now locked.
Last edit: 8 years 3 weeks ago by sozzled.
The topic has been locked.
More
8 years 3 weeks ago - 8 years 3 weeks ago #24 by SteinerPDP
I'm preparing a new J 1.7 site and installed K 1.6.5 (1.6.5_b5005_2011-07-27) with Discuss (plg_kunenadiscuss_v1.6.4_b289_2011-05-07).

Installation went without a hitch. However, there is a "1" showing underneath the Joomla article title (before the date), irrespective of the J template or the plug-in hierarchy.



It only disappears when I disable the plug-in. It also shows on catergory content that is excluded.

[KunenaDiscuss debug: Created #__kunenadiscuss cross reference table. ]
[KunenaDiscuss debug: Constructor called in com_content ]
[KunenaDiscuss debug: onPrepareContent.Allow: Category 8 is in the category map using Kunena category 6 ]
[KunenaDiscuss debug: onPrepareContent: Article 5 ]
[KunenaDiscuss debug: onPrepareContent: Custom Topics disabled ]
[KunenaDiscuss debug: showPlugin: Rendering discussion ]
[KunenaDiscuss debug: onAfterDisplayContent: Returning content for article 5 ]

Same behaviour on safari 5.1, chrome and firefox 6.

Any suggestions?
Attachments:
Last edit: 8 years 3 weeks ago by SteinerPDP. Reason: error in subject
The topic has been locked.
More
8 years 3 weeks ago #25 by Matias
Wait for 2 days until we get the new release out. This has already been fixed in there.
The topic has been locked.
More
6 years 7 months ago #26 by trexeme
high and excuseme for my english....i have a problem whith my site after installation of kunena ....up of my article there is a number 1....if i put offline kunena this number disappears....what can i do to remove this number please ?
thanks to all
The topic has been locked.
More
6 years 7 months ago #27 by 9themestore
Hi trexeme,

I think, the fastest you should post link of your site here. We'll check and give you a solution.

Regards

- Please provide your site url if it has been lived.
- Please share tip if it worked fine with you.
- Don't be shy about using the "Thanks" button below if you found my comment helpful :)
The topic has been locked.
More
6 years 7 months ago #28 by trexeme
The topic has been locked.
More
6 years 7 months ago #29 by trexeme
The topic has been locked.
More
6 years 7 months ago - 6 years 7 months ago #30 by sozzled
Please post your Kunena configuration report. I am fairly sure that i know what my aswer will be but I would like to check the inormation that's in your configuration report. Thank you.
Last edit: 6 years 7 months ago by sozzled.
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.133 seconds