×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Solved K 1.7.2: Userlist columns not sortable

More
7 years 6 months ago - 7 years 6 months ago #11 by D4Real

sozzled wrote: D4Real: The only point that I am trying to make is that, in the past, those two components have caused problems with Joomla (and, of course, that means how Joomla works so that Kunena can run). Follow these two links for more evidence of the problems we've received in the past: Link 1 ; Link 2 . I am not saying that I know for sure that these are the cause of the problem but I am suggesting that they are prime suspects for investigation.

You have a Javascript library loaded by a Joomla extension that is interfering with Joomla Mootools. You need to identify what it is.


Hello Again!

I used my test host to install a FRESH installation of the latest joomla and ONLY added the latest version of Kunena. Then I added 2 new users, so I could sort my user list.

Tried to sort the user list. No sort.

Whats next? (Yes, I know it says mootools upgrade and 1.2 are disabled, but this is how the installation came. I will not do anything additional unless told otherwise)

dforoffice.com/jersey/index.php/forum/recent

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 10M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : beez_20 | author: Angie Radtke | version: 2.5.0 | creationdate: 25 November 2009

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Last edit: 7 years 6 months ago by D4Real.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #12 by sozzled
I have an apology to make to D4Real. There appears to be something peculiar about K 1.7.2. We are investigating the issue. It's surprising to me that no-one else has discovered the problem until now (nearly a month after K 1.7.2 was released) which, I suppose, just goes to show how little-used is this particular feature.

The problem has nothing to do with Joomla 2.5.1. The problem can be reproduced here, at this website:

See www.kunena.org/forum/userlist and you will find that the table is not sortable by clicking the column headings.

I admit that, when I tested this on K 1.7.1 I did not see this problem. Therefore, this leads us to conclude that something occurred in the building of K 1.7.2. I have alerted the project team to the situation and I am looking for an answer on your behalf.
Last edit: 7 years 6 months ago by sozzled.
The following user(s) said Thank You: D4Real

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #13 by GJSchaller
I'm seeing the same issue as D4Real - I have a total of three sites, that all use the same template, and for the most part use the same extensions.

The two sites that have been migrated to 2.5.1 exhibit this issue, but the one still on 1.7.5 does not.

The site on 1.7.5 has the most extensions out of all three installed - I'll see if I can figure out what may be causing the issue.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #14 by sozzled
Thank you for your input to this topic. As I indicated in my previous response, we are aware (from what D4Real has written and from our own observations here at this website) this issue seems to occur in J! 1.5.25 and J! 2.5.1. It is interesting to note that you have not found this to be the case with J! 1.7.5. I will pass this information to the development team for their consideration and reply.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago - 7 years 6 months ago #15 by GJSchaller
I did the following Test process:

1) Clean install of Joomla 1.7.5, Kunena 1.7.2, Akeeba Backup (latest version), and nothing else, using default templates.
2) Create 3 test users.
3) Verify sorting on User List in front end - it works without issue.
4) Update Joomla to 2.5.1 using Extension manager.
5) Verify sorting on User List in front end - it no longer works.

This is using all default templates, options, etc. The only add-on used other than Kunena is Akeeba Backup to make it easy to roll back to an earlier state if needed.

Geoffrey Schaller
Technical Officer
Knight Realms
Last edit: 7 years 6 months ago by GJSchaller.

Please Log in or Create an account to join the conversation.

More
7 years 6 months ago #16 by GJSchaller
The same issue is happening for another Component, Bookmarks Reloaded. Here is their fix for their component - maybe it can help with Kunena:

www.viryasoftware.com/index/19-support/2...t-end-a-back-end#305

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #17 by GJSchaller
Any news on this? It's still happening in Joomla 2.5.2.

Geoffrey Schaller
Technical Officer
Knight Realms

Please Log in or Create an account to join the conversation.

More
7 years 5 months ago #18 by sozzled
I reported that the development team admits that this problem arises from a defect in K 1.7.2.

K 1.7.2 is end-of-life for the K 1.7.x series (the team is not intending to release a "K 1.7.3" (unless there is something seriously wrong - for example, if there's a major security vulnerability discovered) and the project team is not expending effort to remedy this particular problem at this particular time. I understand that's not music to anyone's ears but these are the facts. If, however, there's a member of the community who has found a way to resolve this particular problem and who would like to share their solution, that would be good news, wouldn't it.

The focus of the development team is squarely on K 2.0. The issue has been resolved in K 2.0 but this version is a couple of months from a stable public release. We ask for your forbearance on these matters.

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #19 by dimoss
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 150 seconds | Max execution memory: 512M | Max file upload: 100M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : rt_afterburner | author: RocketTheme, LLC | version: 1.6.0 | creationdate: February 21, 2012

Kunena default template details : Blue Eagle (default) | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: UddeIm 2.8

Third-party SEF components: sh404sef: The file doesn't exist sh404sef.xml !

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None


Hi,

When I click the labels to sort the User List I can't because it goes me to this url:
https://www.tabletennis.gr/index.php#

It should be something like this:
https://www.tabletennis.gr/index.php?option=com_kunena&func=userlist&Itemid=161#

Thanks,

Denis

Please Log in or Create an account to join the conversation.

More
7 years 1 month ago #20 by sozzled
We are aware of this problem. The problem has been fixed in K 2.0.0. There will be no fix offered in K 1.7.2.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.138 seconds