×
Kunena 5.2 RC3 Released (29 Nov 2020)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question Photo Upload

More
9 years 2 months ago #11 by butchtones
Replied by butchtones on topic Re: Photo Upload
Still says "Max file upload: 2M "

Is there someone to fix that other than the Forum Config / Uploads?

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #12 by Hurr1c4n3
Replied by Hurr1c4n3 on topic Re: Photo Upload
This is a part of your screenshot:



There is a path where you can find the file that you'll have to change.
Attachments:

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #13 by butchtones
Replied by butchtones on topic Re: Photo Upload
So, I need to go back and check the .ini ?

Just so I understand:
There's no default limit on the number of pictures that can be uploaded - only the total file size?
If I get the config report to read 20M then everything should work?

Thanks for all of your help here - you've been of great assistance!

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #14 by Hurr1c4n3
Replied by Hurr1c4n3 on topic Re: Photo Upload
There's no default limit that I know of. Just the limit of the filesize of each file and not the total size. I you get the config report to read 20M then you'll be able to upload files to a filesize of 20M and not a total of 20M. Hope you understand my English :-) it's not my native language.

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #15 by butchtones
Replied by butchtones on topic Re: Photo Upload
your english is great! I'll work on this tonight and see what's happening. Thanks for everything!

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #16 by butchtones
Replied by butchtones on topic Re: Photo Upload
Ugh! Still not working. Where am I going wrong? Your guidance it's greatly appreciated!

Here's what my php5.ini loks like:
cgi.fix_pathinfo = 1
file_uploads = On
upload_max_filesize = 20M
post_max_size = 20M

php.ini
register_globals = off
allow_url_fopen = off

file_uploads = On
upload_max_filesize = 20M
post_max_size = 20M
expose_php = Off
max_input_time = 60
variables_order = "EGPCS"
extension_dir = ./
upload_tmp_dir = /tmp
precision = 12
SMTP = relay-hosting.secureserver.net
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="

[Zend]
zend_extension=/usr/local/zo/ZendExtensionManager.so
zend_extension=/usr/local/zo/4_3/ZendOptimizer.so



and last but not least - my config:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 32M | Max file upload: 20M

This message contains confidential information

Joomla default template details : golfmasoninternalnap | author: Kerri Sheldon | version: 1.6.0 | creationdate: August 10 2011

Kunena default template details : Example Template | author: Kunena Team | version: 1.6.5 | creationdate: 2011-07-27

Kunena version detailled: Installed version: 1.6.5 | Build: 5005 | Version name: Babel | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: Jomsocial 2.2.4

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #17 by butchtones
Error message states:

"500 Internal Server Error
Fatal Error was detected!

Fatal Error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 10368 bytes) in components/com_kunena/lib/kunena.image.class.php on line 357

The error was detected in the Kunena Component.

For support click here: Kunena Support

Go back"


Now what??? :ohmy:

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #18 by Hurr1c4n3
Why don't you first upgrade to Kunena 1.7

The config look ok now. So you should be able to upload files greater then 2MB. How many files are you trying to upload and what are there file sizes?

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #19 by butchtones
By upgrading to 1.7 it's not going to effect any of my current configurations, right?

The file sizes are 2 - 3mb and they want to load as many 10 +/-

Please Log in or Create an account to join the conversation.

More
9 years 2 months ago #20 by Hurr1c4n3
You can upgrade without losing anything. Just to be sure and make a backup before you upgrade. I have never had to use the backup, but just in case.

But why upload pictures with a size of 2-3MB? I run a Nature photographers site and we use a maximum of 200kb for each picture and the size is max 800px.

I think when you want to upload as many as 10 pictures with a size of 2-3MB each you run against the maximum allowed memory your website can use at one time. You can increase that limit also if you run your own webserver.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.759 seconds