×
Kunena 5.2 Beta 1 Released (24 Sep 2020)

The Kunena team is thrilled to announce the first public beta release of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 B1 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× Posting guide:

For a quick response, please give us as much information that helps us to understand the problem.
Please read first What information should I include when I ask for help (including how to post my configuration report)?
This category is for:
  • Kunena 1.7 product-related issues only; and
  • when your Kunena forum does not work.
Do not use this category:
  • to request adding to or removing from the standard features of Kunena;
  • if your question is of a commonly asked "how to" nature;
  • if you are not using the latest stable release of Kunena; or
  • ▪ general Joomla or website adminstration matters
General hints: How To Ask Questions The Smart Way .
Please read the guides posted as sticky topics in this category.
Also refer to the FAQs menu tab above for frequently asked questions.

Note: Support for, and all questions relating to, K 1.7 will cease on 31 August 2012. Our advice is, if you are having problems with K 1.7, to upgrade to K 2.x as soon as practicable,

Important Not Receiving Email Notifications

More
8 years 4 months ago #21 by freedomcoach
Hi Matias:

I apologize for my private message saying no one was responding to my posts. I somehow didn't see your latest response of 2 days ago.

Anyways, now you know I'm using your recommended settings and getting two email notifications of every forum post. I suspect there is some easy fix for this but not sure what it is. All suggestions appreciated.

Sincerely,
Howard

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #22 by Matias
Subscriptions feature was broken because of my stupid mistake.. :) Thats why you probably missed the reply.

Now that you're getting emails and you're using CC (everyone can see who's subcribed), I suggest that you check one of those emails who else is getting the email.

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #23 by freedomcoach
Hi Matias,

I'm now satisfied that users are getting the notification emails. My challenge now is figuring out how to stop receiving duplicates of all posts. I feel that there must be something I can turn off to accomplish this.

On a separate but related topic, are there any plans for Kunena 2.0 that would allow users to reply directly to a notification email and have their response added to the relevant thread? As you may know, this kind of functionality is becoming more and more common on social media sites.

At the very least, it would be great if Kunena would "remember" the topic URL in the notification email so that when a user clicked on the reply link, they would be taken to a login page and then directly to the topic to which they are responding.

Howard

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago - 8 years 4 months ago #24 by sozzled

freedomcoach wrote: On a separate but related topic, are there any plans for Kunena 2.0 that would allow users to reply directly to a notification email and have their response added to the relevant thread? As you may know, this kind of functionality is becoming more and more common on social media sites.

Now we're getting off-topic and other people looking for help with their subscription email problems are going to be confused when we start discussing entirely unrelated issues.

Short answer: there are plans for the future but after K 2.0.
Last edit: 8 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago - 8 years 4 months ago #25 by sozzled

freedomcoach wrote: At the very least, it would be great if Kunena would "remember" the topic URL in the notification email so that when a user clicked on the reply link, they would be taken to a login page and then directly to the topic to which they are responding.

Again, this is off-topic to the question about not receiving email notifications.

We've had this discussion elsewhere and, if you want to pursue it, you should use the appropriate topic for it. Let's try to stay on focus in respect of the issues that you have reported about firstly not receiving emails for subscribed topics and, now, you're receiving two emails for every new message that's posted.

Is everyone receiving two emails? Or is it just you who receives two emails? Are both emails exactly the same as one another?
Last edit: 8 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #26 by freedomcoach
I have not had anyone report that they are getting more than one email but I will ask them. Yes, the emails I am receiving are identical.

Sincerely,
Howard

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #27 by Matias
If the emails are identical, I know the reason. You have email address defined in the settings. You should probably change that catch all email address to something else than yours. Just remember to check it once for a while and delete messages it has catched.

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #28 by freedomcoach
Matias:

There is the Forum E-mail Address and there is also the Visible Email Recipient. I have had both of these set to This email address is being protected from spambots. You need JavaScript enabled to view it..

Additionally, my site user email is the same so now I appear to be getting 3 identical notification emails. I'm reluctant to change the Forum Email address to my yahoo address because this would invite the possibility of people sending email to it and it is something I don't check.

What is the best way to set this up so I just get one email on posts? I'd love to know how other admins set up their Kunena notification emails?

Sincerely,
Howard

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago - 8 years 4 months ago #29 by sozzled
I'm really sorry that this problem of yours has gone on for what must seem like centuries. Theoretically, out-of-the-box, no-frills, "no changes made to it" Kunena works; problems always seem to occur when people customise Kunena to suit their unique requirements and, when they don't work, we're left in a bit of a quandary as to how to help people get the best out of the product as they can.

However, apologies don't fix the problem and, no matter how sound the theory might be, there's always something that's buried deep underground that remains mystifying after we've done all that we can to understand and help people who have problems like yours.

You should not have to change anything (unless Matias is able to identify what, exactly, is the cause of this issue). Email subscriptions have been a continuing challenge for as long as I have been associated with the project. There have been improvements made in this area (see What has changed in Kunena 2.0 ) but, K 2.0 is not ready for public stable release at this time and so that will be of little comfort to you.

I say, when all else fails, go back to basics (see, in fact, When all else fails, try this ). At the very least, don't make changes to your live website. Construct a test site where you can verify what's happening and to whom it's happening. You may very well identify exactly what is going on when you use a test site, with a standard, default configuration, and see how things go.

What is the best way to set things up? I really don't know. I just use standard Kunena and Joomla and I hardly change anything. So I'm probably not much use to you. Maybe some other people might have a few good ideas? :dry:
Last edit: 8 years 4 months ago by sozzled. Reason: Fix broken link

Please Log in or Create an account to join the conversation.

More
8 years 4 months ago #30 by freedomcoach
Hi Sozzled,

Are you saying that a basic default Kunena config should generate ONE email notification to me as site Admin? If yes, I can easily change my settings to this default arrangement without any risks to my live site.

As I see it, all I need to do is adjust the 3 variables mentioned in my last post to values that are equivalent to a default arrangement and see what happens.

Given the wide use of Kunena, I could also ask other site admins how they set these variables and how they manage email notification. This shouldn't be rocket science. If it works on other sites, it should work on mine. If it doesn't, there's a reason and I don't buy into the mystery idea. I believe it is traceable and fixable.

I agree that email notifications has been a buggabo with Kunena for years but I am not ready to throw in the towel as your last post seems to suggest. I'm confident there is an answer and I will find it. Troubleshooting sometimes requires a patient, persistent and tenacious attitude.

I'm pretty sure that I'm the only one receiving multiple notifications so it is not a site wide problem affecting all my users. It is a localized issue that only affects me so I can live with this for a while.

I'm going to post this issue on the linkedin Joomla discussion group and see what some of the consultants there recommend I do.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.119 seconds