×
Blue Eagle 5 v1.5.3 has been Released (31 Mar 2020)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.5.3 which is now available for download. This version addresses most of the issues that were discovered in development.

× This category is only for reporting defects or problems with Kunena 1.6 test versions with Joomla 1.6. This is NOT a support forum - there is no support for test versions. Users should NOT install K 1.6 alpha or beta test versions on websites with live production data.

Question Activity Stream Error

More
9 years 7 months ago - 9 years 7 months ago #1 by corejoomla
Hi,

The activity stream option under Kunena config is automatically selected even if there is no JomSocial installed (Also there is no other community component installed like CB). Now when the new post is made an exception is being thrown saying CFactory is not found. I believe the file should be checked before using it something like below:
$API = JPATH_SITE . DS . 'components' . DS . 'com_community' . DS . 'libraries' . DS . 'activities.php';
if(file_exists($API)) {
//do activity stream

May be I am missing something, please correct me.

www.corejoomla.com
Community Polls, Community Answers, Leader Board, Article Suggestions and more..
Last edit: 9 years 7 months ago by corejoomla.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago - 9 years 7 months ago #2 by sozzled
Replied by sozzled on topic Re: Activity Stream Error
corejoomla wrote:

The activity stream option under Kunena config is automatically selected

Are you sure about that? Could you please post your configuration report.

If what you say is true, if the JomSocial activity stream option is automatically enabled by default and if this causes a PHP exception whenever you post a message, then every one of us (who don't use JomSocial) would be in the same situation, wouldn't we?

Is the cure for this problem to disable the activity stream option? If that is the cure then we need to know why the option was automagically enabled in your case.
Last edit: 9 years 7 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #3 by Cerberus
Replied by Cerberus on topic Re: Activity Stream Error
just checked both my test sites and both have acctivity stream diasbled and i have never even looked at that setting till now so they must have been always disabled.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago - 9 years 7 months ago #4 by corejoomla
Here is my config settings. I manually disabled the JomSocial activity stream option to get the issue resolved. Whatever the case, the component should be able to detect the component is installed on or not and then only fire the respective calls to activity stream, as I mentioned the code of first post.
This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 90 seconds | Max execution memory: 128M | Max file upload: 5M

Kunena version detailled: Installed version: 1.6.0-RC1 | Build: 3173 | Version name: Kujadili | Kunena detailled configuration:

Warning: Spoiler!


www.corejoomla.com
Community Polls, Community Answers, Leader Board, Article Suggestions and more..
Last edit: 9 years 7 months ago by corejoomla.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #5 by sozzled
Replied by sozzled on topic Re: Activity Stream Error
I still have my doubts that the activity stream integration is enabled by default as part of an initial installation of K 1.6 - we have not received any other reports from users that this is the situation - but, as long as you have found a solution, I'm pleased that everything is working for you now. B)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.074 seconds