×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question [Merged topic]The great Mootools/Javascript conflict discussion

More
9 years 6 months ago #861 by sozzled
G'day, water, and welcome to Kunena.

I hope you don't mind if I ask you to confirm that you have exactly the same problem that was illustrated in the example given by Ghasem over a month ago. I must say that I've never encountered Ghasem's problem before where only parts of the BBcode toolbar seem to work (but other parts don't).

There's always a danger in writing I have the same problem ... because, more often than not, the "same" problem is really a different problem. Therefore, can we confirm that your problem, water, is the same problem illustrated by Ghasem? Thank you. :)
The following user(s) said Thank You: water
The topic has been locked.
More
9 years 6 months ago #862 by geoffr
Sorry, there are just too many emails to read in this thread to find an answer, and I have spent a full day on this already looking for answers. Is there an answer to the following? -

Q: Is it possible to operate Kunena 1.6.2 properly with the MT Upgrade plugin disabled? (Joomla 1.5.22)

If so, are there instructions?


Help truly appreciated,
Geoff
The topic has been locked.
More
9 years 6 months ago #863 by Matias
Kunena 1.6(.3) should work just fine with Mootools Upgrade disabled -- BUT..

There is a catch.. You can disable Mootools 1.2 from everywhere else except the forum pages. Kunena will detect if Mootools Upgrade has not been load and will force loading it anyway, regardless to the settings. This is because Mootools 1.2 is a requirement to make K1.6 editor, quick reply and others to work at all.

If your main template or modules do not work with Mootools 1.2, you have no other option but not using them together in the same page as Kunena. You may need to install another template to be used together with Kunena or disable your templates Javascript faetures.
The topic has been locked.
More
9 years 6 months ago #864 by geoffr
That's helpful, thanks. We don't need Kunena to work with other modules on same page.
But when I disable MTUpgrade in the plugin settings, Kunena doesn't work properly -- there is no forcing of the MTUpgrade load for Kunena 1.6 happening here.

- Is there a way to see why this is not being forced to happen?

Thanks,
Geoff
The topic has been locked.
More
9 years 6 months ago #865 by water
Thank you sozzled. and yeah i have exactly the same problem. some of my code work while other like insert video,photo and some other like color don't work. its extrange I being using Kunena for long long time and never had this problem. And I can't think of anything new i have install on my site. I had tried to disable the sef and two plugin i have for jomsocial but still same problem. i had tried changing my kunena template to default but still. this is very extrange. Oh and i just updated my kunena to 1.6.3 yesterday to see if that fix it but nope it didn't
The topic has been locked.
More
9 years 6 months ago #866 by sozzled

geoffr wrote: But when I disable MTUpgrade in the plugin settings, Kunena doesn't work properly -- there is no forcing of the MTUpgrade load for Kunena 1.6 happening here. Is there a way to see why this is not being forced to happen?

Thank you. That is a very good question and, yes, there is a simple way to see if Kunena does not work when you diable the System - Mootools Upgrade plugin! B)

I realise that some people may not have enough time to find the technique that I've described several dozen times in this topic (or they may have overlooked the hints "buried" in Mootools 1.2.4 ) and so I will come straight to the point.

(1) Create on your hosted environment a clean, fresh, Joomla 1.5.22 site. Do not change anything; do not change the template. The only changes from a standard installation that you may want to make should be to ensure that Joomla Search Engine Optimization (SEO) is implemented.

(2) Make sure that your Joomla website works and that you can login to it.

(3) Install Kunena 1.6.3. The installation of K 1.6.4 does not enable the System - Mootools Upgrade plugin (you can verify this for yourself).

(4) Test that all the Kunena Javascript-powered functions work in this environment. This will prove whether or not a load of Mootools happens.

I estimate that it will take you about one hour to run this test. I believe that it will be the most useful one hour that you will spend on this problem.

If this procedure works you can then add the other Joomla extensions you used in your production site on this test environment, one by one, making sure that after you install each one that Kunena continues to work. If you follow this process you will discover which extension is the one that is causing the conflict with Kunena on your production environment. The most common extension that causes a Mootools conflict is the site template extension.
The topic has been locked.
More
9 years 6 months ago #867 by geoffr
Thanks Sozzled, a fair answer. however it's hard if not impossible to do on an existing using a RT template.

Regards,
Geoff
The topic has been locked.
More
9 years 6 months ago - 9 years 6 months ago #868 by sozzled
It is not impossible to resolve Rockettheme template issues. The Rockettheme forum provides the answers (if you look there, or ask there). Remember, you paid for the templates and so you can expect their website to provide you with the answers you are looking for. But that's not what I was suggesting.

You asked "how can I be sure that Mootools is being 'forced' to load"; I answered that question by suggesting that you can establish that, if you do not enable the System - Mootools Upgrade plugin, you can establish the answer to that question by seeing how things work if you eliminate the Rockettheme template from the mix of issues. In other words, if you start with the basics you can see that things work. After you establish that the basics work, then you can work through the other issues. Rockettheme is just one of the many other issues that can come into play.

People who use Rockettheme templates - as well as representatives from Rockettheme templates - have provided many useful tips here that deal with the kinds of issues that you are asking about ... if you search for the relevant information .
This is the Kunena forum. Our role here is to make sure that the Kunena extension works. Does this not seem to be a fair response in relation to this issue and the many questions that are asked in relation to it?
Last edit: 9 years 6 months ago by sozzled.
The topic has been locked.
More
9 years 6 months ago #869 by sozzled
This is puzzling. I have not seen this situation elsewhere and I don't know why this is happening in these two isolated cases. I can only guess that there's some kind of Javascript library conflict caused by another Joomla extension. See Conflicting plugins - this article is not the last word on such problems but the general approach is the way that I would recommend you go about things.

You stated that you have the same problem. Do you also have "legacy mode" enabled? If you have "legacy mode" enabled, please disable it. If this does not help, please provide us with your K 1.6 configuration report. Thank you.
The topic has been locked.
More
9 years 6 months ago #870 by thezone
Kunena: You do not have the System - MooTools Upgrade plug-in.
Many features, including Quick Reply and the BBCode editor, may be broken.
Kunena: You do not have the System - MooTools Upgrade plug-in.
Many features, including Quick Reply and the BBCode editor, may be broken.

I installed JFORMS and the jforms do not work unless the new mootools upgrade plugin is turned on..
I have to turn off the mootools upgrade plugin to keep all my forms working
jforms.mosmar.com/index.php?option=com_k...=1&id=3544&Itemid=19

This forum post is exactly what is going on... now we have rocket themes throwing errors, if the new mootools upgrade is running...
What is the solution for all this... omg, site totally screwed due to the new upgrade to 1.5.22

Anyone out there have a solution?
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.257 seconds