×
Kunena 5.2 RC3 Released (Yesterday)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

Question [Merged topic]The great Mootools/Javascript conflict discussion

More
9 years 10 months ago - 9 years 10 months ago #651 by sozzled
helptech: When you finally decide to share with us the information about your website (and I can immediately see two simple problems) you're ready to quit? :(
Last edit: 9 years 10 months ago by sozzled.
The topic has been locked.
More
9 years 10 months ago #652 by helptech
No :( im not quitting by will.. but this problem is not going towards solution :(. Can you please help me? as I have already give up
The topic has been locked.
More
9 years 10 months ago - 9 years 10 months ago #653 by helptech
If I can get this profile thing work.. I will never ever change Kunena forum. It is the best. I have also tried re-installing the forum.. but still no luck.
Last edit: 9 years 10 months ago by helptech.
The topic has been locked.
More
9 years 10 months ago #654 by helptech
Sozzled.. where are you gone? I am waiting for your response.
The topic has been locked.
More
9 years 10 months ago #655 by Helixir

tromp wrote: I have simply solved the problem :) System - Mootools Upgrade (1.2.4) was disabled. Problem was solved after enabling this plugin.

Anyway, Thanks for the support.

Tromp

WoohOOO!!! ITS WORKING!!!! Thx man )))):cheer:
Now i see bbcode buttons ))))
The topic has been locked.
More
9 years 10 months ago #656 by helptech
Im still stuck into this. Have mootools enabled from the start.
The topic has been locked.
More
9 years 10 months ago - 9 years 10 months ago #657 by Helixir
Replied by Helixir on topic Cant edit profile
Hi all.
I cant edit my profile (
Lastest kunena installed.
Open my profile - and link "Изменить"(in english "Edit") not clicable :(



Installed Russian language.
Attachments:
Last edit: 9 years 10 months ago by Helixir.
The topic has been locked.
More
9 years 10 months ago - 9 years 10 months ago #658 by ICIT
Greetings Kunena Community

My Question: Do Kunena use JQuery if so, do it load in "Non Conflict Mode"?

Issue:

My add to cart button will not respond at all on my site "using Tienda". I'd check Tienda forum and they mention that custom Templates or Extentions sometimes use JQuery Libraries. They requested that I follow with the developers, and check if the J Query libraries are loading in "Non Conflict Mode". If not they must be in order for it to work right. I have no way of knowning how to check or where to start.

Can you provide syntax and what file to change to correct issue if Kunena use JQuery Library

Any Help in this area would be greatly appreciated my website is almost finished and I'm stuck.

Joomla ver. 1.5.22
Kunena ver. 1.5.12 I will be upgrading to the latest version soon B)
Browser IE 9 Beta and latest Mozzilla firerfox ver. 3.6.13

Thank You,

ICIT
Last edit: 9 years 10 months ago by ICIT.
The topic has been locked.
More
9 years 10 months ago - 9 years 10 months ago #659 by sozzled
helptech wrote:

Sozzled.. where are you gone? I am waiting for your response.

I live in Australia, which should explain my absences.

The answers to your problem are in two parts:

(1) You need to change your site template. The template that you are using was developed by TemplatePlazza. I'm sorry to say that we've received a lot of complaints from users of Kunena and TemplatePlazza templates and we've asked our users to contact TemplatePlazza - which they've done - but TemplatePlazza has not responded to their requests.

According to the TemplatePlazza website, the last "upgrade" to their software occurred around the release of Joomla 1.5.8. It's a reasonable conclusion, therefore, that their Javascript-powered site templates would have used Mootools 1.1 (that was available around the same time as J! 1.5.8).

The forum at the TemplatePlazza website uses Fireboard software. Fireboard is a J! 1.0 component - it can be run with Joomla 1.5 but only with the System - Legacy plugin enabled.

From the abundant evidence available - and this is not merely my conclusion, but it is the conclusion of others who have struggled to find a solution using TemplatePlazza templates - no matter how "good" these things might look, TemplatePlazza templates simply do not work with K 1.6 and they are not worth the trouble to try to fix. See suggestiones of templates for k 1,6 as one example of what I mean.

(2) Do not use Joomla 1.5.22 in "legacy mode". Please read the very important information about Legacy mode and take action now to remove your dependence on this function now before you have problems later. I am making an assumption, but I think it's probably a reasonable one, that you need to use legacy mode in order to run your TemplatePlazza template. Therefore, if you uninistall your TemplatePlazza template, you probably have no need to run with the System - Legacy plugin enabled.

Conclusion: Your site is running software that is incompatible with Mootools 1.2.4 . A lot of old/legacy software install Javascript libraries that are incompatible with Mootools 1.2.4 - that is what this whole discussion topic is all about. This is the message that we have tried to get across to everyone who has these kinds of problems.

It is entirely possible that the TemplatePlazza template is not the only cause of this Javascript library conflict (just as it's also possible that running "legacy mode" will not appear to have any bearing on your problems, either) but these are two obvious matters that I am recommending that you attend to as your number one priority. If you doubt my sincerity then spend a little bit of time browsing through this topic, research the links that I have posted on the dozens of occasions when I have responded to questions, and satisfy yourself that some of my ideas might actually be worth taking the time to use.

I hope this helps. Let us know how you get along.
Last edit: 9 years 10 months ago by sozzled.
The topic has been locked.
More
9 years 10 months ago #660 by sozzled

ICIT wrote: [Does] Kunena use jQuery if so, do it load in "Non Conflict Mode"?

Thank you for your question, ICIT. Kunena 1.6 does not use jQuery. Please read Mootools 1.2.4
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.611 seconds