×
Kunena 5.1.15 Released (27 Oct 2019)

The Kunena team has announce the arrival of Kunena 5.1.15 [K 5.1.15] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Question [Merged topic]The great Mootools/Javascript conflict discussion

More
9 years 5 months ago #161 by rolandvg99
One more thing: I also had to turn RokGZipper off.
The topic has been locked.
More
9 years 5 months ago - 9 years 5 months ago #162 by sozzled
mik0392: Here's a more scientific test:
  1. Create a brand new test site. Install J! 1.5.20
  2. Install K 1.6 and nothing else
  3. Use the rhuk_milkyway template.
Now do your test and I bet that the BBcode toolbar works. If it doesn't work, let us know. Don't install anything else, yet, until we know that this part works. I think you'll find that the problem is caused by something else you installed before you installed Kunena.
Last edit: 9 years 5 months ago by sozzled.
The topic has been locked.
More
9 years 5 months ago #163 by adminthptngochoi
The topic has been locked.
More
9 years 5 months ago #164 by rolandvg99
I have always used 3rd party templates and those wasn't the root of my troubles. Bees and milky suffered the same errors. For me it was plugins that doesn't support mootools 1.2.
The topic has been locked.
More
9 years 5 months ago #165 by sp3ll
There appears some tools when creating a topic or message.

See here a picture to see better my problem:





Because that does not appear?
The topic has been locked.
More
9 years 5 months ago #166 by sozzled
Thanks, sp3ll. We're well acquainted with the missing BBcode toolbar problem as you will see from this discussion that I merged your message into.

The problem lies in something on your website that is interfering with the Mootools Javascript library.

Javascript conflicts are going to come from one of five possible sources (in descending order of likelihood)

(1) a module
(2) a plugin
(3) a template
(4) a language
(5) a component

Because Kunena is the only component loaded on your web page we can safely eliminate that one.

What you need to do is to find out whether it is a module or plugin or template that's causing your problem. To do this you need to, one-by-one, disable all modules and plugins (except the System - Mtupgrade plugin) to see if this fixes the problem. If it doesn't then you need to look at the template.

But, perhaps we can save you some trouble. What site template are you using?
The topic has been locked.
More
9 years 5 months ago #167 by lulu
Hi everyone

I am using the template Yoo Explorer and i just upgraded my Kunena to 1.6
IT looks beautiful and i simply must have this forum, however I have the same conflicting mootool issue where the bbcode does not display or the menu tabs :dry:

Please help, I really do not want to lose my template as it is part of my branding
I love love love the new Kunena Forum and do not want to downgrade neither

I will appreciate all the help I can get :kiss:
The topic has been locked.
More
9 years 5 months ago #168 by Fenrir
It's sad that I will have to wait for my extension's creators to update to mootools 1.2 before I upgrade from kunena 1.5 to kunena 1.6

If I would want to make a site based only on forum, I better choose phpBB, what I want from kunena is to be a forum solution to be integrated with my whole site, not to run as standalone.

I believe a solution to this problem could be to activate the mootools 1.2 only on my forum section, and not the whole site. But with the standard plugin of MTupgrade from Joomla, I don't know how to do this.


So sad... I can't find a good forum component for joomla 1.5, because all of them causes troubles. The best I've found is kunena 1.5, but 1.6 is a forum component that seems that will work better with joomla 1.6 when it arrives later this year (or next year, I dunno).

Let me know if I say something wrong in English's grammar or syntax
The topic has been locked.

Notice: getimagesize(): Read error! in /home/dafl6903/public_html/libraries/vendor/joomla/image/src/Image.php on line 222
More
9 years 5 months ago #169 by WinuxFF
Its not sad....
Joomla itself introduced the mootools 1.2.4 plugin as it obviously offers much more than old obsolete version.
Kunena just followed the Joomla's step which is good and fairly reasonable step to do.
This is not the passing and holding the ball on the other side of the court, its just how this stuff work.
Blame those component/module/plugin/template developers which dont comply with Joomla.
Its not Kunena's fault.
The following user(s) said Thank You: sozzled
The topic has been locked.
More
9 years 5 months ago #170 by fxstein

Fenrir wrote: It's sad that I will have to wait for my extension's creators to update to mootools 1.2 before I upgrade from kunena 1.5 to kunena 1.6

If I would want to make a site based only on forum, I better choose phpBB, what I want from kunena is to be a forum solution to be integrated with my whole site, not to run as standalone.

I believe a solution to this problem could be to activate the mootools 1.2 only on my forum section, and not the whole site. But with the standard plugin of MTupgrade from Joomla, I don't know how to do this.


So sad... I can't find a good forum component for joomla 1.5, because all of them causes troubles. The best I've found is kunena 1.5, but 1.6 is a forum component that seems that will work better with joomla 1.6 when it arrives later this year (or next year, I dunno).


Sorry but what is your problem exactly? I cannot find a post from you with a request for help (sorry if I missed that)
Most of the conflicts can be easily solved with access to a site, and cleaning up old and or bad code.

If you want help, please ask for it, but please refrain from generic comments like that.

See, had we taken the latest jquery library and shipped it with our component, it would be the very same issue. The problem is not mootools vs jquery, the problem is that there is way too much overuse of them. In reality modules, plugins and components should not even be allowed to load extra frameworks. This is the reason why there is so much incompatibility out there. You can have 3 modules each loading their own version of jquery and with #2 of them the page will already be broken.
The last year we have been chasing jquery issues like that. I strongly believe that Kunena - by going full Joomla and using the built in framework - has done the right thing. We also minify all our js and css - something you expect from every extension out there - yet 99% dont do it and don't care.

The community here will gladly help everybody cleanup their site installs, so new versions can be installed, you just have to ask for help.

We love stars on the Joomla Extension Directory . :-)
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.107 seconds