Kunena 6.0.8 Released (17 Jan 2023)

The Kunena team has announce the arrival of Kunena 6.0.8 [K 6.0.8] which is now available for download as a native Joomla extension for J! 4.2.x. This version addresses most of the issues that were discovered in K 6.0 and issues discovered during the development stages of K 6.0.

This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Merged "This webpage has a redirect loop"

More
12 years 2 months ago - 12 years 2 months ago #71 by none
I've migrated from Kunena 1.5.11 to 1.6.1
I've put out Forum menu as "Kunena Index"
I can open the forum and I can see the index page BUT....

If I want to open my Forum's category I've got wrong url!
Result:

The page isn't redirecting properly.


I try to find out the problem and I spent 2 hours on Kunena's forum (here) but I couldn't find any useful information.
1. I don't use any SEF component and I've never used. I use just Joomla 1.5 basic SEF. If I swich off Joomla SEF url setting in General config the problem with Kunena is being vanished.
2. I didn't change my htaccess file and everything had been working correctly before migration with Kunena 1.5.11.
Now... Everything works perfectly I can open my forum categories. The problem I DO NOT want to swich off basic Joomla SEF. When I open Kunena Index page I have this URL for Kunena menu:

www.mysite.com/forum/index.html?view=lis...catid=1&func=listcat


And when basic Joomla SEF is on and when I want to open my Forum category I've got WRONG URL:

www.mysite.com/forum.html?func=showcat&catid=4


It must be like this:

www.mysite.com/forum/index.html?view=lis...func=showcat&catid=4


When I correct my URL in browser address bar manualy then I can open my category.

What's going on?
Does everyone can expalin it?
Why do I have wrong URL?
Thanks!
Last edit: 12 years 2 months ago by none.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #72 by Josh
Ewww ugly urls! You shouldn't settle for anything less that pretty urls! So if I were you I would look for a good sef extention. :)

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #73 by rkoziol7

rkoziol7 wrote: (3) I have an item ID for my forum. The problem does not exist when I set 'Search Engine Friendly URLs' to 'no', so I guess itemid is right


I have noticed 'your' workaround too ;)

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #74 by sozzled

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago - 12 years 2 months ago #75 by sozzled
We have had a lot of success with users who have corrected errors in their .htaccess file.

When I first encountered stories about this "redirect loop" I thought to myself "How could this be possible? How could it be possible that, if people have never had a 'redirect loop' with their website before (with Joomla SEO setup properly) that by upgrading to K 1.6.1 could possibly cause these problems? This just doesn't make any sense, unless they didn't have Joomla SEO setup properly in the first place!" I had K 1.6.0 (and several development versions of K 1.6 before that) working fine on several websites; I've upgraded to K 1.6.1 and I didn't have a single problem.

So that's how I approached this issue. I approached this problem with the optimism that these problems are not Kunena-caused problems but that they are Joomla problems. And, you know what? I have been right in every case that I have been involved with. People have used the standard unmodified, unvarnished Joomla .htaccess file and they're solved their problem ... every single time.

So, I don't know why people still seem to be having problems. I only know that if you were using Joomla SEO (set up according to the guide I posted in Search Engine Optimization (SEO) in the Wiki and you were having "redirect loop" problems, and you turned off Joomla SEO and you're not having problems, then you probably didn't have Joomla SEO setup correctly in the first place. And the first place you should look is at the .htaccess file.

So, how do you get a .htaccess file that works? Simple. You use the file htaccess.txt that comes with Joomla and you rename it as .htaccess (and you must make sure that you rename it correctly). You can't call it anything you like. It must be named .htaccess (that's dot-htaccess).

Believe me or don't believe me, it's your choice. People think that they have all the answers. People think "I'll just turn off Joomla SEO and I won't get the redirect loop" - and you probably won't - but you won't get all the other benefits of Joomla SEO either. That approach is not a solution. That's just a way of masking the problem.
Last edit: 12 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #76 by none
I have exactly same problem.
Posted here: [url=http://] www.kunena.org/forum/77-general-talk-abo...ith-16-version#71900 [/url]

My htaccess file:
Code:
## # @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $ # @package Joomla # @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved. # @license http://www.gnu.org/copyleft/gpl.html GNU/GPL # Joomla! is Free Software ## ##################################################### # READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE # # The line just below this section: 'Options +FollowSymLinks' may cause problems # with some server configurations. It is required for use of mod_rewrite, but may already # be set by your server administrator in a way that dissallows changing it in # your .htaccess file. If using it causes your server to error out, comment it out (add # to # beginning of line), reload your site in your browser and test your sef url's. If they work, # it has been set by your server administrator and you do not need it set here. # ##################################################### ## Deny access to extension xml files (uncomment out to activate) <Files ~ "\.xml$"> Order allow,deny Deny from all Satisfy all </Files> ## Can be commented out if causes errors, see notes above. Options +FollowSymLinks # # mod_rewrite in use RewriteEngine On ########## Begin - Rewrite rules to block out some common exploits ## If you experience problems on your site block out the operations listed below ## This attempts to block the most common type of exploit `attempts` to Joomla! # # Block out any script trying to set a mosConfig value through the URL RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR] # Block out any script trying to base64_encode crap to send via URL RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR] # Block out any script that includes a <script> tag in URL RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR] # Block out any script trying to set a PHP GLOBALS variable via URL RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR] # Block out any script trying to modify a _REQUEST variable via URL RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2}) # Send all blocked request to homepage with 403 Forbidden error! RewriteRule ^(.*)$ index.php [F,L] # ########## End - Rewrite rules to block out some common exploits # Uncomment following line if your webserver's URL # is not directly related to physical file paths. # Update Your Joomla! Directory (just / for root) RewriteBase / ########## Begin - Joomla! core SEF Section # RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_URI} !^/index.php RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC] RewriteRule (.*) index.php RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] # ########## End - Joomla! core SEF Section

In Joomla:

* Search Engine Friendly URLs: Yes
* Use Apache mod_rewrite: Yes
* Add suffix to URLs: Yes

In Kunena:
Search Engine Friendly URLs: Yes
Do Not Use Category IDs: Yes
Enable UTF-8 Support: No

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Enabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Enabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Exists | PHP environment: Max execution time: 30 seconds | Max execution memory: 64M | Max file upload: 30M

This message contains confidential information

Joomla default template details : yoo_page2 | author: YOOtheme | version: 1.5.0 | creationdate: January 2007

Kunena version detailled: Installed version: 1.6.1 | Build: 3858 | Version name: Timu | Kunena detailled configuration:

Warning: Spoiler!

Third-party components: AlphaUserPoints: Disabled or not installed | CommunityBuilder: Installed (Version : 1.2.3) | Jomsocial: Disabled or not installed | UddeIm: Installed (Version : 2.1)

Plugins: System - Mootools12: Disabled | System - Mootools Upgrade: Enabled | JFirePHP: Disabled or not installed | Kunena Discuss: Disabled or not installed | Kunena Search: Disabled or not installed | My Kunena Forum Menu: Disabled or not installed | My Kunena Forum Posts: Disabled or not installed

Modules: Kunena Latest: Disabled or not installed | Kunena Stats: Disabled or not installed | Kunena Login: Disabled or not installed

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #77 by cuevision
But what to do now? this realy sucks! I do not want to turn off SEF. Aint there be a possibility to modify the htaccess?

Thanks

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago #78 by tracysanz
I have SEO set up correctly, with htaccess.txt renamed to .htaccess, and the corresponding global config settings. This does not solve the problem. I can email you a copy, if you want.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago - 12 years 2 months ago #79 by none
I use Yootheme as well but I dont know about any Yootheme SEF support in the template. I wouldn't think my Yootheme template has anything to do with SEF URLs.

(1) customised .htaccess
(2) issues involving third-party SEF software
(3) menu item with no itemid
(4) the wrong itemid (this would not be generated by the Kunena component)
(5) legacy menu items from K 1.5
(6) the webhosting platform that you are using


1. My htaccess the default Joomla htaccess (Hasn't been modified.)
2. I don't use any SEF software
3-4. The categories' links dont work IN the Kunena forum (I can open the Kunena's index page.)
5. I don't know what to do with that
6. Godaddy Deluxe Hosting

Why did Kunena 1.5.11 work on same platform before and why the new Kunena 1.6.1 doesn't work on same platform with same htaccess, with same Joomla version?

Thanks
Last edit: 12 years 2 months ago by none.

Please Log in or Create an account to join the conversation.

More
12 years 2 months ago - 12 years 2 months ago #80 by sozzled
GoDaddy may be the cause of the problems. See these search results .

There is one certain way to establish the truth. Create a new test site. Start with a totally fresh installation of Joomla 1.5.22 (do not use any Godaddy-hosted scripts to create this file - create the site by uploading the Joomla installation kit from your PC). Rename the htaccess.txt file to .htaccess and enable Joomla SEO on your new site. Install Kunena and nothing else. Please let us know if you then get redirect loop errors. If you do get redirection loop errors with this test site then the problem is GoDaddy.
Last edit: 12 years 2 months ago by sozzled. Reason: fixed broken link

Please Log in or Create an account to join the conversation.

Time to create page: 1.464 seconds