×
Kunena 5.2 RC3 Released (29 Nov 2020)

The Kunena team is thrilled to announce the third public release candidate of Kunena 5.2, a native Joomla extension for Joomla 3.9. This is a development release and should be only be used for testing; this version is not recommended for live websites at this stage.

The purpose of this release is to encourage testing by downloading, installing and identifying any problems or shortcomings that people may discover. K 5.2.0 RC3 is stable and we are aware that people will discover defects. We encourage you to use the forum to report defects, as soon as they are discovered, so that the development team can work through the problems before the release of K 5.1 as a stable product. Reporting defects does not mean that the problems can or will be fixed. The Kunena team is looking forward to hearing your feedback on how well we have achieved our design goals.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Solved Wrong menu item cause 404 error

More
7 years 3 months ago #11 by joomjohn
I tried everything you mentionned, and I will give you access and you can get all needed information, I just want to know what's wrong ! thank you again and sorry to bother you ... here is my informations

This message contains confidential information
The topic has been locked.
More
7 years 3 months ago #12 by joomjohn
Hope you received the administration infos, and if you have the time please don't forget to take a look, maybe you find a solution ! thank you :)
The topic has been locked.
More
7 years 3 months ago #13 by sozzled
I have been busy on a few other things since I last looked at this topic. I will look at your website now to see what I can discover.
The following user(s) said Thank You: joomjohn
The topic has been locked.
More
7 years 3 months ago #14 by sozzled
I have made some progress. This is a very unusual case but I have actually been able to get a working menu for you.

The menu tabs are displayed wrongly (this is a problem caused by the Joomla site template CSS that you're using. I will figure out how to put the tabs right for you and then you should not have further problems with this.
The following user(s) said Thank You: joomjohn
The topic has been locked.
More
7 years 3 months ago - 7 years 3 months ago #15 by sozzled
The problems with the menu tabs are broadly discussed in a number of places on this forum (for example: Menu tabs display vertically ). Essentially, there are some overriding CSS rules in your Joomla site template that affect how menus are rendered (and, remember, the Kunena menu is just another Joomla menu).

One such rule appears at line 85 of your site template file ../itech/templates/zt_genius/css/general.css:
ul.menu li {
    float: left;
    line-height: 35px;
    margin: 20px !important;
    padding: 0;
    transition: all 0.6s linear 0s;
    width: 100%;
}

and changing it to
ul.menu li {
    float: left;
    line-height: 35px;
    margin: 20px !important;
    padding: 0;
    transition: all 0.6s linear 0s;
//    width: 100%;
}

Makes a world of difference, doesn't it?

This isn't, of course, the complete solution but, after spending about an hour at your site, I think you will agree it isn't a bad start. Ultimately, though, you should keep in mind the advice we consistently give in My Joomla site template makes a mess of Kunena ... .

I hope this helps.

This completes our discussion that fixes the problem you were having that caused the 404 Error. It was a strange case indeed.
Last edit: 7 years 3 months ago by sozzled.
The following user(s) said Thank You: joomjohn
The topic has been locked.
  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.094 seconds