×
Blue Eagle 1.5.2 Released (11 Dec 2018)

The Kunena team has announce the arrival of Kunena Blue Eagle 1.5.2 which is now available for download as a native Joomla extension for Kunena 5.1. This version addresses most of the issues that were discovered in K 1.5.1 and issues discovered during the development stages of K 1.5.2.

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Important [Resolved] Upload File 'avatar.JPG' failed.: Not fullfilled dependencies

More
6 years 8 months ago - 6 years 7 months ago #1 by dorkside
Hi,

I'm running Joomla 2.5 - KU 1.7.2 on IIS6 - PHP5 - MySQL 5.5
Great combination i know :unsure:

But when i tried to upload an avatar i got an error saying:
Upload file 'avatar.JPG' failed.: image MIME type () not allowed (jpg,jpeg,gif,png).

So i set the mime check to no.

Then i got an jfile error telling me that he could write to c:/windows/temp/ and afterwards replace to the folder.

So i tought lets put the IUSGR account on read/write permissions on the server.
But and now in the end i get:

Upload File 'avatar.JPG' failed.: Not fullfilled dependencies
And thats where i'm stuck (the error codes are translated i get them in dutch so i hope they are off some use to you)

Anyone has suggestion where i should start looking ?
Last edit: 6 years 7 months ago by .

Please Log in or Create an account to join the conversation.

  • Visitor
6 years 8 months ago - 6 years 8 months ago #2 by
G'day, dorkside, and welcome to Kunena.

The first place that you should start looking for help is to read the posting guide printed at the top of this page and provide us with the information that will help us to diagnose your problem. IIS 6 sites are pernickety things to deal with and the Joomla support forum has literally thousands of questions and advice on the special arrangements that you need to put in place to make Joomla work under a Microsoft environment,

To be honest with you, I've not seen the message "not fulfilled dependencies" before. Have you searched Google for this message in connection with running Joomla and, if so, what information did you find that may help you and others in your situation?
Last edit: 6 years 8 months ago by .

Please Log in or Create an account to join the conversation.

More
6 years 8 months ago #3 by dorkside
Hi,

Thanks for the fast response.

I tried googling but i only found one post with the same problem.
Only he was running linux and he fixed it with editing his php.ini

I tried that but the setting was already correct...

Probably i just need to step up a notch to something like an ubuntu server or a newer windows server.

But i still think its a permissions issue...

Please Log in or Create an account to join the conversation.

  • Visitor
6 years 8 months ago - 6 years 8 months ago #4 by
dorkside wrote:

Probably I just need to step up a notch to something like an Ubuntu server or a newer Windows server.

Probably, possibly ... who knows? Without seeing meaningful information from your configuration report, it looks like this falls into the category Support for PC-hosted websites (e.g. WAMP, XAMPP) . In other words, if this site is not accessible on the internet, then you're pretty much on your own trying to figure out what to do next.

It could be a permissions issue. What do you know about setting permissions on a Windows server environment? You may find more information by searching around docs.joomla.org

Are we correct in concluding that your site is not hosted on a commercial webserver? This looks like a server configuration issue, not a Kunena support issue to me.
Last edit: 6 years 8 months ago by .

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #5 by dorkside
Well i configured everything correct now on my IIS and PHP.ini.
I can upload files to the forum and everything.
But when i try to upload an avatar larger than 200x200 i get the depencies error...
So i gues it is a simple problem somewhere in the config of my kunena.
this is the config file:

This message contains confidential information

Database collation check: The collation of your table fields are correct

Legacy mode: Disabled | Joomla! SEF: Enabled | Joomla! SEF rewrite: Disabled | FTP layer: Disabled |

This message contains confidential information
htaccess: Missing | PHP environment: Max execution time: 30 seconds | Max execution memory: 128M | Max file upload: 100M

Kunena menu details:
Warning: Spoiler! [ Click to expand ]

Joomla default template details : justbusiness-fjt | author: FJT | version: 2.5.0 | creationdate: 16-03-2012

Kunena default template details : Example Template | author: Kunena Team | version: 1.7.2 | creationdate: 2012-01-31

Kunena version detailled: Installed version: 1.7.2 | Build: 5215 | Version name: Omega | Kunena detailled configuration:

Warning: Spoiler! [ Click to expand ]

Third-party components: None

Third-party SEF components: None

Plugins: System - Mootools Upgrade: Disabled | System - Mootools12: Disabled

Modules: None


So if i can upload jpeg in my posts i gues my server is setup correctly...

Please Log in or Create an account to join the conversation.

  • Visitor
6 years 7 months ago - 6 years 7 months ago #6 by
Thank your for your configuration report which looks like it provides all the necessary clues we need. Even if you do not think you require dynamic image resizing, Kunena needs GD library support because uploaded avatar images must be resized so that they can be used in the different parts of the forum where you want them to appear. Do you have a GD library installed? Your configuration report shows that you have not installed a GD library. :dry:

As I wrote in my first response to you, IIS servers require special care. It is beyond the scope of this forum to go into all the special things that you need to examine if you want to run Joomla under a Microsoft webserver environment. You could start, however, by looking at these three documents: You may also want to ask some questions about at the Joomla support forum about anything else that you may need to do in order to serve IIS via TCP port 8070.

So, no, I think you still have a bit of work to do to properly configure and equip your IIS 5 server in order to run Kunena.
Last edit: 6 years 7 months ago by .

Please Log in or Create an account to join the conversation.

More
6 years 7 months ago #7 by dorkside
Thanks for the help.
Now i know where it went wrong.

I need to use port 8070 of other port because everything below 1024 is blocked by my ISP.

Thank you for the info you can close this thread is you want !

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.102 seconds