×
Blue Eagle 5 v1.6.2 has been Released for Kunena 5.2 (20 Jan 2021)

The Kunena team has announce the arrival of Kunena template Blue Eagle 5 v1.6.2 which is now available for download. This version addresses most of the issues that were discovered in development.

REQUIREMENTS
Blue Eagle 1.6.x requires Kunena 5.2.x to work with

× This is for users to help other users, to discuss topics that are related to forum administration in general or problems in running Joomla. This is not the place to ask for Joomla support. If you want assistance with Joomla please ask at forum.joomla.org

Question Complaints about Mootools

More
9 years 7 months ago #11 by sozzled
Replied by sozzled on topic Re: Related to mootools
I really don't know any more than I have written, any more than the answers I found from my own limited research. I understand that some people have issues here. I simply do not know enough about these things to give you a better explanation that what I have given. If you would like more information, please ask at forum.joomla.org

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #12 by kapilsahu
Replied by kapilsahu on topic Re: Related to mootools
Thank you for your support as you say about 40kb there is one hope i see that i have found some way to optimize my site atleast some way. I will try to find myself if this is possible or not & if yes i will told to you also.
Again thank you for your support.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #13 by karmany
The mootools-more.js library is horrible!: 233 KB!

Why the website "kunena.org/forum" does not load the library mootools-more.js? -> 233KB
Why the website "kunena.org/forum" does not load the library mootools-core.js? -> 86KB
(kunena.org/forum -> mootools.js only -> 33KB)

We can do the same?

File Attachment:
- "Tu sitio para aprender, enseñar y compartir"

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #14 by karmany
Replied by karmany on topic Re: Related to mootools
AHHHH!!! I've seen the code

Because kunena.org -> Joomla! 1.5 and use System Mootools Upgrade Plugin -> mootools.js


For Joomla! 1.6-1.7 -> JHTML::_ ( 'behavior.mootools' ); -> moootools-more.js + mootools-core.js -> 233 KB + 86 KB = 319 KB!!!! Grrrrr -> On mobile devices this size is too large. (As kapilsahu said).

For developers:
Will it possible to create a System Mootools Upgrade Plugin, as in joomla 1.5 or will conflict with mootool-more and mootools-core? I'll try it on my website.

A forum would not have a size of 500-600KB... is too large. And... when this website(kunena.org) is upgraded to Joomla 1.7, 1.8...? kunena.org/forum -> 600-700 KB?????

sozzled: "All websites servers should be set to compress ("GZIP") files" Yes, but I think that is the last solution.

File Attachment:
- "Tu sitio para aprender, enseñar y compartir"

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #15 by xillibit
Replied by xillibit on topic Re: Related to mootools

karmany wrote: AHHHH!!! I've seen the code

Because kunena.org -> Joomla! 1.5 and use System Mootools Upgrade Plugin -> mootools.js


For Joomla! 1.6-1.7 -> JHTML::_ ( 'behavior.mootools' ); -> moootools-more.js + mootools-core.js -> 233 KB + 86 KB = 319 KB!!!! Grrrrr -> On mobile devices this size is too large. (As kapilsahu said).

Hello,

The weight can't be reduced more because the files are already minified (compressed)

karmany wrote:
For developers:
Will it possible to create a System Mootools Upgrade Plugin, as in joomla 1.5 or will conflict with mootool-more and mootools-core? I'll try it on my website.

What do you want achieve ?

I don't provide support by PM, because this can be useful for someone else.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago - 9 years 6 months ago #16 by karmany
Replied by karmany on topic Re: Related to mootools
xillibit: "What do you want achieve ?"

Mootools (v1.2.5) for Joomla! 1.5 -> mootools.js (approx. 40 KB)
Mootools for Joomla! 1.6-1.7 -> moootools-more.js + mootools-core.js (approx. 319 KB).

Why not use the System Mootools Upgrade Plugin in Joomla 1.6-1.7?

File Attachment:
- "Tu sitio para aprender, enseñar y compartir"
Last edit: 9 years 6 months ago by karmany.

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago #17 by sozzled
Replied by sozzled on topic Re: Related to mootools

karmany wrote: Why not use the plugin System Mootools Upgrade Plugin in Joomla 1.6-1.7?

Please read what I wrote in msg #2 in this topic. K 1.6 uses the Javascript libraries that are included with whatever version of Joomla you are running. If J! 1.6/1.7 happens to ship larger Javascript libraries that not our problem. If you have a problem with "large" Javascript libraries in J! 1.6/1.7 please post your question to Joomla (forum.joomla.org).

Please Log in or Create an account to join the conversation.

More
9 years 6 months ago - 9 years 6 months ago #18 by karmany
Replied by karmany on topic Re: Related to mootools
Ok. Topic closed. I will not talk about this...
thanks

File Attachment:
- "Tu sitio para aprender, enseñar y compartir"
Last edit: 9 years 6 months ago by karmany.

Please Log in or Create an account to join the conversation.

More
9 years 1 week ago #19 by sunny33days
Replied by sunny33days on topic Re: Related to mootools
Hi Karmany, I'm trying hard to speed up my site, I was curious what was your fix was this? What version of Joomla and Kunena setup do you recommend for speed and lower server resources?

Please Log in or Create an account to join the conversation.

More
9 years 1 week ago #20 by Jiminimonka
Replied by Jiminimonka on topic Re: Related to mootools
Sunny33days,

If you read the post above you will see it is 6 months old. You will also notice, if you read, that Mootools is part of Joomla, not part of Kunena, so direct your Mootools questions to forum.joomla.org/

Thanks.

Please read the FAQ.
Only one question per topic.
Search before you ask a question.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.088 seconds