×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

× Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Question -1 - An error occurred. Impossible to copy the selected file.

More
11 years 1 month ago #1 by daiasobi
Dear Sirs,

First iwould like to thank you so much for your fantastic extension Kunena.
I have got a Joomla! 1.5.11 in Italian with Community builder 1.2.1 in Italian installed. I had got also Fireboard 1.0.5RC2 (the last version available) and I decided to migrate to Kunena 1.5.3. First I tried with another Joomla! 1.5.11 installed in a sub-directory (not the root) of my domain, I use it for experiments. I adopted following steps: uninstalled modules related to Fireboard and then Fireboard; disactivated the legacy plugin, installed Kunena 1.5.3. Perfect, no problems! Thank you again.
I tried the migration of the production site the following day, but with a different order of steps (because I was sleepy, ahime’!): disactivated legacy plugin; uninstalled modules (success); uninstalled Fireboard (failed, not uninstalled completely, tipical non legacy mode error); installed Kunena (error); uninstalled Fireboard in legay mode (success).
During installation of Kunena 1.5.3 (com_kunena_v1.5.3_stable_b1688_2009-06-15), I’ve got this error message in a blank screen (not the usual Joomla! one) “-1 - Si e’ verificato un errore. Non e’ possible copiare il file selezionato.” that means “-1 - An error occurred. Impossible to copy the selected file.” (please see the unusual screen error image herewith attached). The server is in Japanese (I live in Japan) so I think the error message is from Joomla!.
Now Kunena 1.5.3 works apparently well, but I noticed following problems:
1. When I am not logged in, if I click “users list” link in the stats panel, it displays the list even if it is for registered users only.
2. In the user list of 1. it displays also users not enabled, and displays as online users logged in backend only.
3. It considers users logged in the backend, as viewing the board twice: as guest and as user.

I tried to uninstall and reinstall Kunena (in native mode of course) several times but the same error occurres each time.
I noticed the user list link points to www.mydomain.com/forum/userlist.html also when I am not logged, I think it should point to www.mydomain.com/component/comprofiler/userslist.html when I’m not logged.
Also the link to the last member points to www.mydomain.com/forum/fbprofile/userid-138.html when I am not logged, instead of www.mydomain.com/community-builder-user-...rofile/username.html

I would be very glad if you could help me to solve the problem I caused.

Thank you in advance.

Yours faithfully
Attachments:

Please Log in or Create an account to join the conversation.

More
11 years 1 month ago #2 by fxstein
SOrry for the problem and the bad error message.

We just switched to the Joomla file class but the error handling is not the way it was expected.

This points to a permissions thing. Please make sure all files and directories under

/components
/administrator/components
/media/kunena/attachments/legacy

are writeable to the userid you are using. The user id used to install via webserver or ftp credentials must be

either the owner of the files or belong to the same group

you can check this via

ls -la

You might have to update the owner of the files via

chown -R apache:apache *

(-R for recursive, apache as a sample userid same for group - this depends on your setup)

Then make sure that all files in these paths

are chmod u+w and g+w (owner and group can write to them)

That should do the trick.

FYI in some cases installing a Joomla upgrade via terminal and tar xvf will change some of the file and group owners to an id not present on your system. If you find files and directories that have numbers instead of names for owner and group, use chown -R username:groupname * to reset them as per your system setup.

I know this sounds complicated, but I hope it helps.

Everybody else please chime in if you feel I missed something.

fxstein

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
11 years 1 month ago #3 by Freestyl24
I had this same problem...I had to reset the permissions in /media/kunena/attachments/legacy to resolve.
Hope this helps.

Please Log in or Create an account to join the conversation.

More
11 years 1 month ago #4 by daiasobi
I really appreciated the tempestivity of your answers, but as my Joomla! website is running on a shared server, I cannot access the command line.
Instead, I tried to install over after changing chmod in 777 to nearly all files and directories related to kunena, included image/fb... folder, but the error is still the same. Now I am running without stats.
I hope you could suggest an other way.

Thank you for your precious time.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.090 seconds