×
Kunena 5.1.18 Released (30 Jun 2020)

The Kunena team has announce the arrival of Kunena 5.1.18 [K 5.1.18] which is now available for download as a native Joomla extension for J! 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.

Important Avatar doesn't appear

More
10 years 4 months ago - 10 years 4 months ago #11 by sozzled
Replied by sozzled on topic Re:Avatar doesn't appear
I have made an important discovery. There appears to be an issue with the webserver as the following image (the result of my attempt to re-install Kunena on morfina's website) shows:



The user's website, by default, uses PHP 4. This behaviour can be changed by adding the following lines to the .htaccess file:
php_value safe_mode Off
 
#Run PHP 5 instead of 4
Addtype application/php5 .php
After making this change, I was able to successfully install Kunena.
Attachments:
Last edit: 10 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago - 10 years 4 months ago #12 by sozzled
Replied by sozzled on topic Re:Avatar doesn't appear
I think I've solved morfina's problem. :woohoo: But, first, let me recap the diagnosis of the cause:

We were running K 1.5.8 with customised site template, customised .htaccess file and non-standard Joomla file permissions. At this time, if you attempted to upload an avatar image you would receive no error message but, also, no image would be uploaded or displayed.

With the user's permission, I attempted to establish a stable base platform. I attempted to upgrade the site to J! 1.5.15 but I kept running into permissions obstacles. Then I ran into a PHP 4/5 conflict (fixed with the .htaccess file) when I attempted to reinstall K 1.5.9.

At long last, after establishing a stable base platform, I discovered that when you attempted to upload an avatar you would hit the problem described in Avatar upload problem >> JFile::copy: Cannot find or read file: for which there is a workaround.

The workaround is to change the following Kunena configuration setting:

Avatars » Avatar Settings » Image Processor = none

This is not a "normal" setting; this is not even a recommended setting but it is a solution to the problem. This seems to suggest that there is something defective in the background.

My thanks to morfina who has been very patient with me throughout this exercise - he's been up all night - not because he wants his problem solved but because he wants to help other users who might be in this situation. Therefore, he's the one who deserves a lot of the credit. B)
Last edit: 10 years 4 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #13 by morfina
Replied by morfina on topic Re:Avatar doesn't appear
Realy a big THANK YOU sozzled for solving the problem. :)

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #14 by Victorius
Replied by Victorius on topic Re:Avatar doesn't appear
sozzled wrote:


Can you please provide the URL and a test account to demonstrate the problem being discussed in this case?


I can, but the forum is in Hungarian, I'm not sure if you understood even a word. :cheer:

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #15 by Victorius
Replied by Victorius on topic Re:Avatar doesn't appear
sozzled wrote:

This is not a "normal" setting; this is not even a recommended setting but it is a solution to the problem. This seems to suggest that there is something defective in the background.


Before I switched off the image processor option I hadn't even been able to upload any pics. With an error message I'd been refused.

I switched it off then the avatar uploads were successful, though they didn't show. :S

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #16 by Victorius
Replied by Victorius on topic Re:Avatar doesn't appear
I am getting nuts! I have checked and tried everything - same result. If I upload any of the default avatars they are shown, but if I try to upload an avatar from my pc, it says upload was successful, but not avatars are shown. :S :S :S

I even tried to replace the php file with the one you submitted, but it resulted in more php error messages. (Interestingly the content of that php file and the one comes with my installation archive is pretty different in a lot of rows!)

I feel desperate becaues it should work, but it doesn't. I have spent so many hours working on it and I don't know what to do. :(

Please Log in or Create an account to join the conversation.

More
10 years 4 months ago #17 by sozzled
Replied by sozzled on topic Re:Avatar doesn't appear
Victorius: Please read carefully what I wrote in message #41205 earlier. There are several issues mentioned in that message. We can add the "Image Processor" GD2/GD1 issue to that list, too.

You say you have checked "everything". For each of the dot-points listed in message #41205 , what are your responses?

Victorious wrote:

I even tried to replace the php file with the one you submitted, but it resulted in more php error messages. (Interestingly the content of that php file and the one comes with my installation archive is pretty different in a lot of rows!)

What were the PHP errors? What version of PHP are you running? There is only one difference (at line 335, there is one less { )

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #18 by abasel
Replied by abasel on topic Re: Avatar doesn't appear
I've tried all the processor options.... none worked.

I got no error messages but the imaged didn't appear to upload either

Please Log in or Create an account to join the conversation.

More
9 years 9 months ago #19 by sozzled
Replied by sozzled on topic Re: Avatar doesn't appear
abasel: this discussion dealt with a problem involving a template issue in K 1.5.9. Is that your problem, too? Please read the notice for this K 1.5 Installation, Upgrade and Migration Archive category:

Topics that are moved into this category are generally considered to be closed. Users may want to add additional information but these topics should not be resurrected in order to discuss new problems or unrelated matters.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.147 seconds