×
Kunena 5.1.14 Released - Security release (13 Aug 2019)

The Kunena team is proud to announce the arrival of Kunena 5.1.14 [K5.1.14] which is now available for download as a native Joomla extension for Joomla 3.9.x. This version addresses most of the issues that were discovered in K 5.1 and issues discovered during the development stages of K 5.1.14. This update fixed 1 security issue.

Question SOLVED: BBCode legend (Help) doesn't work

More
10 years 2 months ago #11 by latino
Hi:

Just want to tell that the BBCode help do work for the message submit, preview and cancel buttons. It doesn't for the bbcodes (only the bold displays a button that reads 'bold' out of the yellow bar). Maybe the problem is still rokcandy. However, disabling the macros left can ruin my Refraction theme.

However, will test so the problem can be further narrowed.

Later

B)

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago - 10 years 2 months ago #12 by latino
Hi Again:

Well, I installed Kunena 1.0.10 and CB 1.2.1 in site that was running Kunena 1.0.9 without CB. The BBCode Help still works.

Also, I installed RokCandy, RokTabs, Roknewpager, RokNavmenu and roktwitie. bbcode help do work. I do noticed that rokCandy have fewer macros activated than the one included on the site #1 (which was a rt - joomla install). Site 1 have various macros which can't be disabled.

So, the problem lies within those macros still active or a CB Plugin. Will try to test more tomorrow. Sorry to not have identified the problem.

Later
Last edit: 10 years 2 months ago by latino.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #13 by latino
Hi Again:

Well, I tried unpublishing most CB plugins and the bbcode help still not work on site with the problem. I tried disabling even other joomla plugins. This makes me think problem could be the 'other' rokcandy macros that I can't disabled.

Well, hope someone will identify the conflict soon.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #14 by Matias
RokCandy has known issues with Kunena. If someone wants to investigate it, I'd like to take fix to the next Kunena release.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #15 by grumblemarc
Some of the macros in RokCandy can be disabled. Just need a list for which ones to disable for Kunena.

We love stars on the Joomla Extension Directory . :-)

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago - 10 years 2 months ago #16 by sozzled
I'm confused. We now have two discussion topics ongoing about this matter. One is "solved" (or is it?) and the other is "not solved" (or is it?). This is how I summarised the situation in the other discussion :

Before going any further, to clarify the term tooltip, we are not using the commonly-used definition (i.e. the small yellow box that pops up when the mouse cursor hovers over a window element) - this is not an issue, I believe. We are discussing the behaviour of the Kunena message editor that uses Javascript to display alternative text in a yellow box below the toolbar.

I fairly convinced that Joomla has a bearing on this problem. Joomla 1.5.10 brought many security changes aimed at preventing badly-formed or malicious Javascript exploits. J! 1.5.11 has built on those foundations. Good thing too! B)

This is my personal experience of the problem:

  • Local PC development site: J! 1.5.7 website, K 1.0.10, CB 1.2.1, JEvent 1.5, JA_Purity template - BB tooltips work.
  • Beta test site: J! 1.5.7 website, K 1.0.10, CB 1.2.1, JA_Purity template - BB tooltips work.
  • Production site: J! 1.5.10 website, K 1.0.10, CB 1.2.1, govista template - BB tooltips did not work until I implemented the fix described in message #18844 .
This is a summary of what I know of JComeskey's experience:
  • Production site: J! 1.5.10 website, K 1.0.10, JEvent 1.something, RocketTheme template - BB tooltips does not work even after implementing the abovementioned fix; changing to rhuk_milkyway template has no effect either.
  • Secondary site: J! 1.5.10 website, K 1.0.8 - half the BB tooltips work but half of them don't. ( #18896 ); after upgrading to K 1.0.10 the behaviour is identical to the production site.
This is a summary of what I know of latino's experience:
  • Production site: J! 1.5.11 website, K 1.0.10, CB 1.2.1, RocketTheme Refraction template - neither BB code nor smiley worked until disabled RokCandy plugin; BB toolips do not work ( #18927 )
  • Secondary site: K 1.0.9 - BB toolips work. ( #18902 )
Have I summarised the important facts correctly? Do you see anything in common, anything I've overlooked?

In JComesky's case he was still using CB 1.2 - had not upgraded to CB 1.2.1 - while he was experiencing his problems. To my knowledge he has not yet reported whether upgrading addressed his problems.

Although in latino's case he had upgraded to CB 1.2.1, to my knowledge he has not yet confirmed if he has applied the fix (described in message #18844 ) I referred to above.

It's possible that RocketTheme plugins are involved. It's also just as probable that we don't yet have all the information. I still maintain that Joomla 1.5.10 (or higher) is involved to some degree, too, in creating the conditions that cause the problems to occur in the first place.
Last edit: 10 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #17 by JComeskey
sozzled wrote:

In JComesky's case he was still using CB 1.2 - had not upgraded to CB 1.2.1 - while he was experiencing his problems. To my knowledge he has not yet reported whether upgrading addressed his problems.

Although in latino's case he had upgraded to CB 1.2.1, to my knowledge he has not yet confirmed if he has applied the fix (described in message #18844 )I referred to above.

It's possible that RocketTheme plugins are involved. It's also just as probable that we don't yet have all the information. I still maintain that Joomla 1.5.10 (or higher) is involved to some degree, too, in creating the conditions that cause the problems to occur in the first place.


I agree with this. I will work on upgrading one of the sites to CB 1.2.1 tonight.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago - 10 years 2 months ago #18 by sozzled
I'm cautiously optimistic that, if you have a website based on Joomla 1.5.10 (or higher) with Community Builder and Kunena 1.0.10 that
  1. you will experience the inoperative BBcode tooltip problem; and
  2. you need to apply both:
    • the fix (see #18844 ); and
    • upgrade to CB 1.2.1
in order to resolve the matter completely. I suspect that the "involvement" of RocketTheme is coincidental in this case.
Last edit: 10 years 2 months ago by sozzled.

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #19 by JComeskey
Yep, Sozzled, you nailed it.

I upgraded to CB 1.2.1 on the secondary site (not live yet) and all of my issues seem to be magically fixed - tooltips, redirect after posting, preview function.

I will post this at the other thread too. And I still need to upgrade CB at the ORRRC site. (That is a volunteer job, so I figured the billable work might make more sense to do first. :laugh: ) But I can confirm that the solution is to upgrade to CB 1.2.1 and to implement the kunenaforum.js fix.

Wow. Thanks for the help guys, I really appreciate it!!!

Please Log in or Create an account to join the conversation.

More
10 years 2 months ago #20 by sozzled
@JComeskey: thanks for the vote of confidence, mate! :laugh:

Indeed it looks as if we've collectively found the way to solve this problem. I would like this thread to remain open for a little while longer so that latino can confirm that his problem, too, was addressed by the total solution. B)

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Time to create page: 0.093 seconds